Questions tagged [my-site]

an intranet user's personal site

108 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6
votes
0answers
873 views

REST API to get Frequent Sharepoint Sites programmatically?

Sharepoint Online offers a view of the frequent sites of the current user. It is available in the home page of the "My Site" of the user. I'm asking if there is a REST API (or something like) to get ...
6
votes
1answer
1k views

Remove and recreate all personal sites - mysites - remove them from DB without waiting ~25 days

Is there a easy way to remove (delete) all personal sites and recreate them all over again? I also want to delete them from the sql. I've tried to delete personal sites and run my site clean up job ...
6
votes
1answer
2k views

Something deleted user data from MySite

One of our users received this warning: The My Site of [USER] is scheduled for deletion in 14 days. As their manager you are now the temporary owner of their site. This temporary ownership gives ...
4
votes
0answers
460 views

User Profile Picture not Showing for some site URLs

I migrated a website from SP2010 to SP2016 (not directly, used 2013 in between). After I mounted and upgraded the content database on the customer's system an error was shown and the site (http://site)...
4
votes
1answer
375 views

SharePoint Online Delve

Hi all I need to add logo and link in Delve page. SharePoint not support customization in Delve page. How to add that any idea. Also can i change the order of the display field like contact field ...
3
votes
0answers
44 views

Users are not able to create My sites. No new site collections will be created when they edit their profile

I am working on an on-premise farm 2013. now i have configured the My sites under user profile as follow:- now usually when a user access the my-site such as http://servername/my/Person.aspx?...
2
votes
0answers
357 views

Enable “Community Site Feature” on a subsite site, will prevent users from accessing it unless they have contribute permision on the root site

I am working on an on-premises team site collections 2013. now the site collection have some sub-sites which have unique permissions. and for certain users they only have contribute permission on the ...
2
votes
0answers
100 views

Access Denied when browsing a user profile Organization

I am in an environment that crosses between two Domains. The First domain has user profiles and mysites (although the mysite feature is disabled). The People search is used to find organizational ...
2
votes
1answer
683 views

How to add Calendar to every “My Sites” Globally?

I want everyone in my company have their personal calendar in their SharePoint "My Site". It means that I don't want to log in with everyone's credentials and go to their "my site" and add calendar ...
2
votes
0answers
91 views

Branding on MySite

We have a main site and a mySite. Both are having the same branding with the top navigational bar. This menu contains some URLS linked to main site. I am using a sitemap to generate the relative URLs ...
2
votes
0answers
923 views

Retrieve the Large Thumbnail Profile Image in Sharepoint 2010 My Site Profile Page

I am trying to retrieve the profile image with the _LThumb URL, in my people search result. But since my container is 30x30px, SharePoint is automatically retrieving the profile image with _MThumb on ...
2
votes
0answers
144 views

Searching using custom properties on mysite

I have a question about using a search to search on custom properties, properties that I've added myself to profile page. So what I have now a user profile page with some standard properties like ...
2
votes
0answers
938 views

Extending the ConsolidatedNewsFeedWebPart Newsfeed Web Part in order to render custom Activity Events in SharePoint 2010 MySites

The title says it all and I imagine this question will evolve as more people provide input. I will try to update with the current answer and/or working code for all to use. The question is about ...
1
vote
0answers
39 views

Getting “No User Profile Application available to service the request. Contact your farm administrator.”

I am getting "No User Profile Application available to service the request. Contact your farm administrator." while enabling "Self-Service Site Creation" User profile application has been created and ...
1
vote
1answer
24 views

Error with newly created Blog sites

We are running SharePoint 2013 Server on prems. I am trying to create a new blog site under my personal site. There is a link in the quick lunch but when I click on it, it points me to: https://[...
1
vote
1answer
38 views

Users Unable to Edit Profile Properties

I have an on-premises SharePoint 2016 server. The user Profile Service is set up to sync with Active Directory and all of my users have been pulled in. When a user goes to "About Me", they can click ...
1
vote
1answer
31 views

MySite: Custom links lost after “Change the look”

SharePoint 2016 on premise migrated from 2013 approx 1 year ago. After "Change the look" on MySite site collection on all personal sites user created custom links are lost. See red area in screenshot....
1
vote
0answers
37 views

My Sites Link not appearing

This is SharePoint 2010 environment. I am trying to configure My Sites in a test environment, I have the User Profile successfully running and have created My sites web application and site collection ...
1
vote
0answers
55 views

Is it possible to add a global navigation bar to my sites?

Is it possible to add a global navigation bar to my sites for SharePoint 2016? I've tried enabling publishing features on the my site host but it did not work.
1
vote
0answers
36 views

Do I need MySite Web App per UPSA?

In SP2013 farm I have 2 User Profile Service Applications (UPSA) running and working fine. UPSA1 --> Using SharePoint Synchronization >> associate with WebApp1 UPSA2 --> Using ADI >> Associate ...
1
vote
1answer
95 views

My Sites Error -There was a problem retrieving the latest activity. Please try again later

I've had some problems with Distributed Cache with SharePoint 2013 which I think are resolved, however in the newsfeed section of MySites the following error is visible: SharePoint returned the ...
1
vote
0answers
52 views

SharePoint 2010 - A Web Part or Web Form Control on this Page cannot be displayed or imported. The type is not registered as safe

I have been stuck on this error and am unable to solve it since the past few days. I have googled all I could, but none of the solutions seem to work for me. I'll go through all the steps I've done ...
1
vote
1answer
720 views

SP2016 “About me” link does not work

We migrated from SP2013 to SP2016. The link "About me" in the top right corner points to http://portal/Person.aspx, by clicking it the system tells Page not found. I took a look in the Central ...
1
vote
0answers
30 views

Profile image in my site

I have changed the profile image for My site in a SharePoint 2013 environment. I want to add a question that. Is the profile image in synchronization with the Active Directory. ? I do not have a ...
1
vote
0answers
117 views

Can we set newsfeed and secondary owner for my site clean up using PowerShell script ?

Can we set newsfeed and secondary owner for my site clean up using PowerShell script? Please refere path "Central Admin-->Application Management-->Manage Service Applications-->User Profile Service ...
1
vote
0answers
22 views

Add a SharePoint site to Office applications using audience targetting

I'm wondering if it's possible to add a Sharepoint site in the "Save As" -> "SharePoint" option with the office mobile clients (like Word) without the need to have already manually added the site ...
1
vote
1answer
2k views

SharePoint doesn't create mysite

I configured Mysite on Sharepoint 2013 by creating a new webapp and a root site collection but no site collection is created when user click on "About Me". It redirects to my.xxxx/person.aspx If i ...
1
vote
1answer
65 views

Where is the MySite user details stored - SharePoint 2010 (My settings)

I have a user who needs to change is name when he opens up mysite and then "my Settings" - the URL is https://XXX/MySite/_layouts/userdisp.aspx I have checked the user profile and it all seems ok ...
1
vote
0answers
100 views

This website declined to show this web page

I have recently migrated my sites from SharePoint 2010 to SharePoint 2013. I have done this by attaching the 2010 content database in to SQL, creating a new web application and then mounting the ...
1
vote
0answers
348 views

My Site Cleanup Job deleting My Site immediately

Our current environment is SharePoint 2010 and have My Sites enabled. The My Site Cleanup Job is also enabled and set to run every hour as set by default. Once an account is deleted or deactivated ...
1
vote
1answer
201 views

Move-SPUser - only changing upa but not mysite url with new id

SharePoint 2010: Move-SPUser works however in SP 2010 it does not change the mysite url to reflect user's new id. for example, mysite.fu.bar/sites/oldid so it should be mysite.fu.bar/sites/newid. The ...
1
vote
0answers
177 views

Remove users and their MySite using CSOM

I have a scenario in which I have to remove the users from SharePoint after they have left the company. Say, I have 5 users who left the company. So I'll write a CSOM code to read the names from a ...
1
vote
0answers
615 views

News Feed settings Showing error in SharePoint 2016 mysite

I am working in SharePoint 2016 Beta 2 version, in which I created my site host which is working correctly, but I am not getting how to configure News feed Settings. To see the error please refer ...
1
vote
1answer
228 views

Permission issue trying to export Picture to AD

I am working on a SharePoint 2013 on-premise farm. I am trying to set the property for picture to export to AD. I have set everything as described in this blog: http://blog.areflyen.no/2012/06/05/...
1
vote
0answers
761 views

On Premise SharePoint 2013 host web Rest api cross domain access from MySite

We are using the OOTB REST api to access data from the Host Web App using JavaScript. The MySite has been set up under a separate Web App following the recommendations of Microsoft. This site needs ...
1
vote
0answers
247 views

How to embed a link (or preview) of the “About Me” MySite of a certain user into a page in SharePoint 2013

In a SharePoint 2013 publishing page, I want to insert contact information for technical support for the SharePoint portal. I wonder how I can insert a link (or even preview) to my MySite which then ...
1
vote
0answers
94 views

Displaying list items in my site

I have a need to display content from a list in another site collection on every users My Site page - About Me (/person.aspx). The list is essentially responsibilities for users. So the list needs ...
1
vote
0answers
512 views

Rest API create personal site enque

I'm trying to provision My Site by utilizing SharePoint JSOM or REST API. The JSOM code snippet (below) gives System.UnauthorizedAccessException and REST call gives me a 401. The goal here is to ...
1
vote
0answers
49 views

How to implement a delegate control for only the mysites?

I created a delegate control and it works fine. I add it to the AdditionalPageHead. Now it is visible on all Master Pages. I would like to make it only visible on the My Sites. How to do this without ...
1
vote
0answers
311 views

SharePoint 2013 document library size bigger than the sum of file sizes

I have a user that on his my site put lots of files into a document library. The threshold for the site is 20 GB. The document library shows in the settings that it has used circa 18 GB. The problem ...
1
vote
0answers
89 views

An unknown user profile error has occurred

Full error An unknown user profile error has occurred. Try recreating this user profile or updating the user profile from the directory service to resolve this problem This error has appeared on ...
1
vote
1answer
275 views

JSLink use with content type hub and my sites

Content type hub is used in this scenario, to syndicate the content types and columns to several web applications. I'm setting the JSLink property in a custom field definition, to load the .js file. ...
1
vote
0answers
674 views

Connect to Office not working Sharepoint 2013 and Windows 7

I cannot for the life of me get the Connect to Office to create any sites within my Sharepoint sites directory on my local computer. It does create the link in the "My Sites" Quick Links, but i don't ...
1
vote
1answer
83 views

Deploy VS solution (List) to all users' “My Site”

I wrote a custom document library that we use to manage our Proof of Activities at work. I used VS2012 for development and our portal is based on SP2013. Is there any way besides PowerShell to ...
1
vote
0answers
3k views

Cannot find site lookup info for request Uri

I am investigating an issue with users cannot follow up site and looking at the logs I find the following error. Action: Follow a site Error: Something went wrong Sorry, we couldn't follow ...
1
vote
0answers
231 views

SharePoint 2013 - Display a Disclaimer or Terms of Service when creating MySite

We need to Display some Kind of disclaimer / Terms of usage when a user initially creates his mysite. Best solution would be to Display a Website with a "Yes" / "No" choice... Clicking "Yes" would ...
1
vote
0answers
836 views

My Site Settings: Language Options not applied

On a SharePoint 2013 Server CA Services Applications > User Profile Service > Setup My Sites: The Language Options check box: Allow user to choose the language of their personal site Checking in ...
1
vote
0answers
280 views

Where does the redirect from ViewPost.aspx to Post.aspx happen?

When a user wants to open a blog post, he clicks on a link like: http://mysitehost/my/[USERNAME]/Blog/Lists/Posts/ViewPost.aspx?ID=2 SharePoint now redirects the user to http://mysitehost/my/[...
1
vote
0answers
139 views

E-mail sent from My Site Cleanup Job

I want to change the template of the e-mail sent from the My Site Cleanup Job. I know the template is somewhere at ..\Microsoft Shared\Web Server Extensions\14, but i cant find the template. Can ...
1
vote
0answers
188 views

Active Directory group not displayed in membership tab in sharepoint 2010

I recently activated My Site in my portal. I wanted to display the users that belonged to a particular distribution list in active directory. I have created distribution list and also security group ...