Questions tagged [http-400-bad-request]

The request could not be understood by the server due to malformed syntax. The client SHOULD NOT repeat the request without modifications.

Filter by
Sorted by
Tagged with
0 votes
1 answer
44 views

Getting a 400 back when posting to SharePoint 365

I'm trying to POST a new item to my SharePoint 365 list via Java 6. (I know this is an old version. This is a technology constraint I have to work with.) First I worked out the url and the body and ...
user avatar
  • 1
0 votes
0 answers
12 views

When trying to add a .xls attachment from a shared email inbox to a sharepoint list, I keep getting a 'Bad Gateway' error

I am trying to add an attachment from a shared email inbox to a sharepoint list. The email that I recieve is a hard-coded email and when the flow extracts the attachment, it extracts .png images from ...
user avatar
0 votes
0 answers
140 views

Create SharePoint Site Pages automatically with Power Automate - BadGateway

I was following this video https://www.youtube.com/watch?v=QtBqeEEOgdE and this blog http://www.sites.se/2018/08/sharepoint-modern-pages-microsoft-flow/ because I need to use a template and populate ...
user avatar
0 votes
0 answers
19 views

Camlex Query CSOM throws 400

I have a WSP that includes Camlex.Client 1.4, the WSP contains the DLL and targetDeployment is in GAC. On the server, the GAC contains the DLL. I have a REST Service that connect to my ...
user avatar
  • 121
0 votes
1 answer
67 views

400 Bad request when filtering data using the autogenerated ID column

Been hitting my head and have no idea what I am doing wrong. I have couple columns in a list and I want to update the Column field by choosing the ID field. Below is the URL that I generate but throws ...
user avatar
1 vote
1 answer
344 views

Why http PUT can upload file successfully to SharePoint?

We are using SP2016 on-premise. In order to handle security test I prepared a PowerShell script to test upload with PUT/POST. $Digest = $response.getcontextwebinformation.FormDigestValue $headers = ...
user avatar
  • 4,016
5 votes
2 answers
10k views

Execute CSOM code from .net core

Is there any option to execute CSOM code from .net core application? I have a bot solution from this i need to store all the conversation details in SharePoint list. When executing the code, i am ...
user avatar
1 vote
0 answers
111 views

Copying list item between sites with REST/JSON HTTP Call from Workflow: Why wont these columns copy?

This is a re-post with more information hoping for a better response. I have 2 lists in a SharePoint site with the following columns: List 1 project ID = Single line of text event type = Choice ...
user avatar
  • 763
0 votes
0 answers
16 views

How to copy non-text site columns between sites using REST/JSON

I am attempting to set up a SharePoint 2013 workflow which will copy the contents of a list item from a subsite to a logging list on its parent site. I have successfully set up the HTTP web service ...
user avatar
  • 763
0 votes
2 answers
3k views

SharePoint POST REST API returning error code 400

I'm attempting to create an item in SharePoint on premise 2016 list using Java and SharePoint API. Forgive me if I missed it - I see a few related questions but they do not seem to really answer my ...
user avatar
  • 1
0 votes
0 answers
144 views

Starting SharePoint 2013 workflow using REST from another workflow fails the first time but works on retry

I have two SP 2013 workflows. One (WF1) does a number of things, but at the end of WF1, I'm calling another SP 2013 workflow (WF2) using REST. WF1 runs both on create and change and conditionally ...
user avatar
  • 1
0 votes
2 answers
5k views

Rest API POST method getting 400 Bad request

Im new on SharePoint 2016 and i want "POST" items to list ` var data = JSON.stringify($scope.formData); console.log(data) data = data.replace(/[{}]/g, ''); var datavalue = "{__metadata:{'type':'...
user avatar
0 votes
2 answers
229 views

sharepoint API rest custom column http 400

I have a list in sharepoint, where I have put the totals of the columns I am interested in. ID Count=50 Certification Count=9 I want to display these counts on another page. I have found a code to ...
user avatar
  • 1
1 vote
1 answer
713 views

Azure function CSOM The remote server returned an error:(400) bad request

I am trying to make a simple query to sharepoint online using Azure function created in VS2017. My code looks like below: List mylist = myweb.Lists.GetByTitle(listName); CamlQuery camlQuery = new ...
user avatar
1 vote
1 answer
3k views

Call SharePoint web service from excel macro vba

I have called SharePoint web service from excel macro VBA with following code from here: Sub CallService() Call Add_Item("List1", "https://contoso.sharepoint.com/sites/site1/", "test item", "...
user avatar
  • 3,197
0 votes
0 answers
295 views

400 Bad Request Invalid verb - when trying to update field value with REST API [duplicate]

I am trying to update a field value in a SharePoint document library through SharePoint REST API. I am successfully when I try using Fiddler. When I send a command through Java code, it gives 400 Bad ...
user avatar
  • 95
0 votes
1 answer
3k views

Getting HTTP error 400 Bad Request - Invalid URL when trying to update SharePoint field

I am trying to update a field inside a Sharepoint document library using Apache HTTPClient, but keep getting HTTP error 400 - Invalid URL. The code and the output is as mentioned below. Please advise ...
user avatar
  • 95
2 votes
0 answers
147 views

Request Header issue on SharePoint site

I've made a team site using several Excel Web Access web parts, and a little custom CSS. However, after opening two sub sites, and going for the third, the Excel Web Access web part isn't rendering, ...
user avatar
  • 1,746
0 votes
0 answers
399 views

SP 2013 - Updating a multi-value lookup field via the REST API - Bad request

I am trying to update a multi-value lookup field via the REST Api in a workflow. It works great in Fiddler. However, when I run the workflow I get a 400 bad request error. When I log everything in the ...
user avatar
3 votes
1 answer
2k views

Getting http 400 bad request after database attachment

Our client attached a database from SP 2013 testing environment to SP 2013 Production env. Now they are getting the error: http 400 bad request. I have never done this before, so I was wondering if ...
user avatar
  • 1,897
0 votes
1 answer
97 views

can not add a new value in a custom list

I running: - Windows server 2012 - Sharepoint 2013 - Visual studio 2013 I created a custom list in visual studio and when i'm trying to add a new value inside I got "unexpected response from ...
user avatar
2 votes
2 answers
5k views

Url Length Limit when uploading SharePoint 2013 Online/OneDrive for Business

I'm working on a Winform application which allows a user to upload documents to Onedrive for Business. Essentially you select a folder you want to upload, this creates all of the folders and then ...
user avatar
  • 935
1 vote
1 answer
3k views

400 (Bad Request) ERROR while trying to use JS files in Content Editor Web Part

So, I added some code in Content Editor Web Part and code is started like this: <script src="/<MyURL>/_layouts/15/SP.Runtime.js" type="text/javascript"></script> <script src="/&...
user avatar
0 votes
2 answers
2k views

SP Online: Diagnosing a 400 Bad Request error with UserProfiles.asmx and $.ajax

I'm trying to save a user profile field back to SharePoint using Javascript running within the portal. The request is kicking back a 400 error with no real descriptions of what the error might be. ...
user avatar
2 votes
1 answer
1k views

ListData.svc with complex filters, Internet Explorer, 400 Bad HTTP request,

I have a problem understanding how ListData.svc can be debugged using IE8 and IE9. I have a URL that looks like this: hostname:8181/_vti_bin/listdata.svc/ImageBanners?$filter=endswith(Path,'TopLeft'...
user avatar
0 votes
1 answer
506 views

400 bad request when connecting to sp2007 kerberos

I am trying to connect from a java client to sharepoint. I manageds to connect to sp2010 ntlm sp2010 kerberos sp2007 ntlm but sp2007 kerberos throws the error below(maybe from the iis): what could ...
user avatar
  • 199
4 votes
2 answers
18k views

ListData.svc returns Error 400: Bad Request in Visual Studio

I wanted to use the REST Service in an application. So when I add the service reference in Visual Studio I get this error There was an error downloading 'http://myMainSite/sites/subSite/_vti_bin/...
user avatar
  • 427