Questions tagged [feature]

set of functionality that can be turned on at a particular scope level

82 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
0
votes
0answers
79 views

How to get feature from GUID on Project Online

In Project Server on-prem I know how to get a feature/web part from its Guid using PowerShell, but since we can't use PowerShell in Project Online (right?), how can I see the name of a feature or web ...
0
votes
1answer
99 views

What is the value of SP2016 Feature Packs? I don't have Software Assurance

I've been asked to build a case for why we need the Feature Packs for SharePoint 2016 as we didn't originally budget for Software Assurance. Since there has not been one yet (that I know of) for ...
0
votes
0answers
45 views

Error deploying in production ONLY

I have a SharePoint solution, consisted of 2 features. The first feature is consisted of 5 SharePoint 2010 workflows, and some web pages. The second one is empty and has a feature event receiver that ...
0
votes
1answer
1k views

How to remove site collection feature “web template feature of exported web template xxx”

I have several site collection features that start with the name web template feature of exported web template. When I use get-spfeature I am unable to see anything with a displayname that matches and ...
0
votes
1answer
42 views

How to hide new site option in feature is activated event

How to hide new site option in feature is activated event. when feature is deactivated it will visible to users
0
votes
1answer
18 views

How to open and manipulating an already developed and deployed SharePoint feature using visual studio

After SharePoint migration from 2010 to 2013, I have imported a solution, using power shell, which was developed for the SharePoint 2010. Now the feature is deployed and is available but does not ...
0
votes
1answer
222 views

How to find out per PowerShell Script if a Solution is activated and where it is activated

i have a Solution with the name My.Solutionname as the result of it i have a WSP with the name My.Solutionname.wsp It includes one Site and one Web scoped Feature. I have a SharePoint 2013 Farm ...
0
votes
1answer
78 views

Order of Items in a single feature

Can we set order for items in a single feature? I was trying to create a site column of type lookup for which the lookup-list should be created first after that only we can create the column. In my ...
0
votes
1answer
35 views

Improper feature Id attribute error

Hi I am getting Improper feature Id attribute error. I try to deploy a feature to a site using visual studio 2013. google cant help me so i ask here. this is my feature.xml: <?xml version="1.0" ...
0
votes
2answers
24 views

How can I manipulate List-Data on a certain SiteCollection using a TimerJob?

I need to periodically execute code that reads and writes ListData within a certain SiteCollection. My first thought was a TimerJob. Can I create a TimerJob using a SiteCollection-Feature? How can I ...
0
votes
1answer
29 views

Feature not activating, til 2nd attempt, no error

I have a custom feature that, when activated, alters a document library (adds content types, sets up views, attaches a workflow). For some reason, the first time I activate the feature nothing seems ...
0
votes
1answer
24 views

Object Reference Error when trying to check for activated features using windows forms app

var feature = spSite.Features.SingleOrDefault(sf => sf.Definition.DisplayName.ToLower().Equals(strFeatureName));//Error block if (feature != null)//if feature is activated { ...
0
votes
1answer
1k views

“The associated workflow has been deprecated.” error

I've got 2013 workflows, deployed from WSP package. After last Deploy from VS2013 I've got workflows behaving the way that first execution on item created is ended after starting with the "The ...
0
votes
0answers
59 views

“Resource not found ” when page is deployed using a feature

I am running through deployment problem. I have a feature with pages and required dlls. When I deploy the solution it gets successfully deployed. I can see feature (active) in my site. I can see ...
0
votes
0answers
543 views

SharePoint Online master page not being added to subsite

In SharePoint Online I have created a new Site Collection with a custom master page, and the master page styles are displaying fine. Now when I create a subsite they do not get the master page ...
0
votes
0answers
499 views

MySite Feature Activated Document Library

I would like to modify the Document Library for each users mysite during creation to include a custom content type. I figured a feature would solve this problem. However, when activating the features ...
0
votes
0answers
54 views

HarePoint Knowledge Base and DevExpress won't leave me alone!

I installed the HarePoint Knowledge Base for SharePoint. I have since removed it. Periodically, despite the fact that I have removed every trace of the application I can find, all of my web.config ...
0
votes
1answer
297 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
1answer
49 views

Can't find MissingFeature

I have a question, basically when i run Test-SPContentDatabase I get an error "MissingFeature" with an ID. I used the Feature Admin, this one doesn't give any faulty features or whatever, i checked ...
0
votes
1answer
234 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
45 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
175 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
0
votes
0answers
1k views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
2k views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
0
votes
1answer
29 views

How to find feature including a specific element

this migth be a really easy question, but I could not find any solution for that. I'm using VS 2012 and want to find which features are using a specific element. Since I got lots of Features in my ...
0
votes
0answers
75 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
1answer
81 views

Remove a list from all site collections when a feature is uninstalled

I have a site scoped Feature which specifies a list as such: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> <...
0
votes
1answer
126 views

Add custom code for solution upgrade

I have a solution for SP2010. Let's call it s.wsp. I had version 1 of s.wsp and now I have version 2 of s.wsp. Versions 1 and 2 share three common features: A, B and C. Version 2 adds a new feature D. ...
0
votes
0answers
81 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
0answers
36 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
0
votes
0answers
513 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with columns),...
-1
votes
1answer
79 views

Can't see feature on my webApplication

I did a solution for a SPJobDefinition. Feature scope is WebApplication as required. I have event FeatureActivated but when i deploy solution. When i go to CA -> Manage WebApplication -> select one ...