Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Questions tagged [feature-activation]

A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

Filter by
Sorted by
Tagged with
0
votes
1answer
203 views

Execute SPFeatureReceiver only on site creation

We have recently upgraded from SharePoint 2007 to 2010 and we aren't yet ready to train users on the new interface, so I've created a SPFeatureReceiver that will set the site template back to the 2007 ...
0
votes
3answers
2k views

Getting SPWeb Object in two ways

I want to access SPWeb object in feature under its FeatureActivated method. There are two ways to do this: Public Override void FeatureActivated(SPFeatureReceiverProperties properties) { //Method 1 ...
0
votes
1answer
239 views

Unable to get list “Calendar” list in feature while creating site

I want to create custom calendar list programatically. SPListTemplate template = web.ListTemplates["Calendar"]; var newListID = web.Lists.Add(fromTitle, description, template); But i cannot do this ...
0
votes
2answers
3k views

Error occurred in deployment step 'Activate Features': Invalid field name

SharePoint Error message Error occurred in deployment step 'Activate Features': Invalid field name.{guid}
0
votes
3answers
3k views

rootWeb.AllProperties[“__InheritsCustomMasterUrl”] = “True”; not working

I am developing a branding project, in this project i have custom master page, i can successfully deploy it and automatically apply to the root web. But i want all the subsites inherit the master page ...
0
votes
2answers
2k views

What is the Correct Way to Deploy Solutions in Foundation 2010 Via C# API

I am on a team developing a "portal" for SharePoint Foundation 2010. I am responsible for making the installer which sets up a new instance of SharePoint. It handles more than just the installation ...
0
votes
2answers
11k views

Access Denied when activating features implementing SPFeatureReceiver?

We've developed several features who implement the SPFeatureReceiver interface. When trying this out in the development environment it first failed until I found this script from the MSDN: function ...
0
votes
2answers
5k views

Enable-SPFeature Fails

I am trying to activate a feature using PowerShell Enable-SPFeature but receive the following error: Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level ...
0
votes
1answer
1k views

Error When Attempting to Activate a Feature Scoped at Web Application Level

I have created a feature to apply a custom masterpage and stylesheet to my SharePoint web application. This feature is scoped to Web Application level. My problem is that if I try and activate it ...
0
votes
3answers
1k views

Feature Activation Error(Cannot Add Dll to GAC)

We have created a feature, which has 2 application pages. One is to activate the user control and the other one is for database configuration. For the database configuration, the user has to provide ...
0
votes
2answers
71 views

Get deactivated features with PnP

I am trying to automatically install and activate a solution to our Project Server 2019. I have already installed the solution with Install-PnPSolution, but I cannot activate the feature. When I ...
0
votes
1answer
17 views

SP19 - Site Collection Features - shows all features across all collections

We have a new Sp19 installation with 4 different web applications with 1 site collection each. We deployed then some farm solutions to the specific sites. When I open the list of Site Collection ...
0
votes
2answers
1k views

SharePoint Modern Hub Site - unable to Activate SharePoint Server Publishing Infrastructure

I have a SharePoint Hub site and I have created a sub-site using the Records Center template. With this being so, I have attempted to Activate "SharePoint Server Publishing Infrastructure" under Site ...
0
votes
1answer
112 views

How to revert to default form for content type

I added a new feature and inside FeatureActived wrote following code to open my custom task form whenever user clicks on task title. SPContentType myTask = web.ContentTypes["Workflow Task"]; myTask....
0
votes
1answer
163 views

Enable-SPFeature : Field not found

I have a feature that creates a library in a site collection root, as we have 30000 site collections I cant activate it manually, I have to activate it with powershell. The problem is that when I ...
0
votes
1answer
29 views

Error: Feature not installed and blocking for application for using this site Template

I have site template created from old site which is WSP file, both server versions are same(SP2013 on premise) What is the reason behind this three feature is not installed is there any dependencies? ...
0
votes
1answer
20 views

How to deploy different files in single feature for mulitple subsites?

I need to deploy different images into picture library for different sub sites in a single feature, I mean I have five images, I need to deploy the first two image in the site collection, third image ...
0
votes
1answer
533 views

Unable to activate the feature while deploying the solution in sharepoint 2013?

I tried to deploy our solution in visual studio while activating the feature it throws an error message like these Error 2 Error occurred in deployment step 'Activate Features': Failed to load ...
0
votes
1answer
47 views

Activate site scoped solution programmatically

I have a requirement to Activate/Deactivate Site Scoped Feature. I need to Activate/Deactivate on sites. I did deploy it and when I try to add it to a site collection an exception appear. This's the ...
0
votes
2answers
747 views

Add Custom Web Part to newly created page programmatically

I created a custom web part for SharePoint 2013 and I would like it to be added to a blank page that is created for it. I looked it up and found out, that the I can add an Event Receiver to the ...
0
votes
2answers
143 views

Feature Event Receiver activation, application page set as default newform

I am trying to set the application page as default. So I have added an application page in layouts folder using visual studio. But when I run the code in feature activation I am trying to get the file ...
0
votes
1answer
33 views

Feature Activation User

Which user context is used in feature activation receiver? Is it current user (when activating from WebUI)? I have to call a service in feature activation receiver and I have to know which user ...
0
votes
1answer
355 views

Feature activation terminated if code is running too long (SP 2010)

Is it possible that feature activation will fail or will end unexpectedly (without any exceptions in ULS) when it takes too long for code to finish the job? We have a feature which during activation ...
0
votes
1answer
243 views

Edit default Pagelayout on feature activation

My site is in SharePoint 2010. I want to edit the content of PageFromDocLayout.aspx default page layout on feature activation. My feature is on site collection level. I want to change the ...
0
votes
1answer
837 views

Activating web feature from event receiver doesn't do anything

I have the following code that should run to automatically disable the Minimal Download Strategy feature when a new site is being provisioned. Unfortunately nothing happens. No errors are captured in ...
0
votes
1answer
120 views

Why SharePoint can't activate a dependency feature, while upgrading a feature?

This question is regarding dependency feature activation, while upgrading a feature to latest version. Suppose, There is a feature called MasterFeature_0_0_0_0 and it is being upgraded to ...
0
votes
1answer
1k views

ListDefinition and ListInstance failures with custom content type

In VisualStudio 2012 I have a custom content type that I want to use in a ListInstance. When I create a ListDefinition or ListInstance using VisualStudio and add my ContentType I get feature ...
0
votes
2answers
5k views

Error occurred in deployment step 'Activate Features' while trying to deploy an event receiver?

I cant seem to figure out what the issue is while I try to deploy my event receiver targeted at a particular list on my site. All I am trying to do in the event receiver is to check (on itemUpdating)...
0
votes
2answers
350 views

SP2010 - site collection feature not activating on MySite creation

I've created a new feature in a pre-existing project, closely modelled on features that are already within that solution. These features activate automatically when a new MySite is created, but the ...
0
votes
2answers
3k views

Sharepoint package installation - Feature is not visible in Site collection -> settings

I am not very experienced with Sharepoint 2010 and I am having trouble installing a package. I downloaded a package from "iLove SharePoint" as I need to call web service from a workflow. The package ...
0
votes
1answer
460 views

Convert site to a publishing site

I need to activate publishing features on certain sites without losing their site content (lists and libraries). The publishing feature is activated in site collection. When I try to activate the ...
0
votes
1answer
752 views

Failed with 0x80004005 to create the view query or web parts for web

Feature 1 creates Site Columns Feature 2 creates Content Type and adds the site columns created by feature1 Feature 3 creates a List definition for mylist I have two Web tempaltes. I have added ...
0
votes
2answers
2k views

“Thread abort exception” in event receiver after adding a solution?

I am developing an event receiver for the web provisioned event. It does quite a few things, culminating to add and deploying a solution and activating a feature from it. When I do the following: ...
0
votes
2answers
323 views

When Re-activating Feature, All Content Shows Up Twice

Let me preface this by saying that I am brand new to Sharepoint, so the answer to this question may be obvious. I have a blog feature on one of my Sharepoint sites that I need to make changes to. ...
0
votes
2answers
256 views

Feature not activating after sharepoint 2007 upgrade to sharepoint 2010

After the 2007 to 2010 SharePoint upgrade i have taken notice that when i try to activate a feature under the site collection admin for a root site page and also with manage site features i keep on ...
0
votes
1answer
280 views

Custom Site Content type is not getting mapped for the required taxonomy field

I have a custom project site template which is coded in c#.net VS 2010, I have deployed the projects related to the project site template into central admin through VS After deploying the solution I ...
0
votes
2answers
1k views

Errors when attempting to install a sharepoint 2010 feature

I'm attempting to install and activate a feature containing a Timer Job. When I execute the install-spfeature cmdlet I get the following error. What is the source of my error? PS C:\Users\crmadmin>...
0
votes
1answer
634 views

Error on Activate Features on deploying SharePoint Skin

Error occurred in deployment step 'Activate Features': Object reference not set to an instance of an object. I just can't figure out where the error is occuring. Found some blog posts concerning the ...
0
votes
1answer
158 views

Custom list Feature problems

I created a custom list definition, which works well. When i deploy, the list definition is added, when i retract, the list definition retracts properly. I also created a list instance from said ...
0
votes
1answer
72 views

How do you activate a feature on promotion?

When promoting a wsp and you have 1 or more features you wish to activate as soon as promoted, how do you do so without manually activating them on the site they are deployed to?
0
votes
1answer
1k views

Event receiver feature update

I am developing an event receiver in VS2010. To test the event receiver I deploy it to development using the functionality within VS 2010. This works without problems. However my concerns start when ...
0
votes
1answer
230 views

Include SPDatabase for Backup

SharePoint 2010 I've been Googling for days now, trying to find an answer to my issue. My boss wants to see if it's possible to do the following upon feature activation: Create a custom database to ...
0
votes
1answer
1k views

Site Collection Feature won't go away

I have a custom Feature, with Site Collection scope, that won't go away even after I delete the Web Application, the Content Database, the IIS Web Site. I have uninstalled the Solution that ...
0
votes
1answer
955 views

Access denied when adding web application features programmatically

My goal is to programmatically activate a Web Application scoped feature. I'm running this code from a feature receiver of a Web scoped feature. I'm logged in as a Farm Administrator. My app pool ...
0
votes
1answer
22 views

sharepoint publishing feature changed my main navigation bar

I enabled sharepoint publishing feature, because I needed anchor feature. For some reason, this changed my navigation bar. I do not know what to call it, but the first link was moved above the other ...
0
votes
1answer
14 views

Create an owner group firstly include the site current user and assign permissions full control to it

i have used this code but when i deploy nothing changes : public override void FeatureActivated(SPFeatureReceiverProperties properties) { SPSite site = properties.Feature.Parent ...
0
votes
1answer
54 views

How can I get/identify feature titles/names in REST?

SharePoint 2013 I'm able to view all site collection active features via the following endpoint _api/site/features. I'm unable to match any of the guids to feature titles; the endpoint doesn't seem ...
0
votes
1answer
97 views

Error when Deactivating Farm Feature - Failed to load receiver assembly

I have a farm feature that was updated by PowerShell with the following: Update-SPSolution -Identity FILE.wsp -LiteralPath "PATH\TO\FILE.wsp" –GACDeployment I'm trying to deactivate and then ...
0
votes
1answer
429 views

Feature activation fails “Unable to locate the xml-definition” for content types not in the feature

SharePoint 2013 on-prem. Farm solution with Web scoped feature that deploys without problems when deploying directly from VisualStudio. However, when trying to activate the feature in the normal way ...
0
votes
1answer
84 views

SharePoint 2010 Error adding a Feature Event Receiver

I want to add a Feature event receiver, that add a webpart to a page, I followed the steps in this link But when I tried to deploy it , I hade the following error : Error occurred in deployment ...