Questions tagged [feature-activation]

A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

Filter by
Sorted by
Tagged with
1
vote
2answers
1k views

How to add a picture library to a communication site

I cant find the picture library add-in for a modern communication site. Is there any feature i need to enable?
0
votes
1answer
13 views

SP19 - Site Collection Features - shows all features across all collections

We have a new Sp19 installation with 4 different web applications with 1 site collection each. We deployed then some farm solutions to the specific sites. When I open the list of Site Collection ...
3
votes
2answers
834 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
2
votes
2answers
1k views

Activate Approval, Collect Feedback, and Collect Signatures workflows for a site collection?

All workflows are active except for Approval, Collect Feedback, and Collect Signatures. Everything I've read says to go to Site Collection Features and activate Workflows. I've done this, but ...
0
votes
1answer
22 views

Custom TimerJobs are not showing under Job definition in SharePoint 2013 when activated the feature at web level

I have custom Timer jobs solution deployed at site and web level scope. When I activated the Site level scope features I am able to see the Custom Timer Jobs under Central Admin Job Definitions, but ...
1
vote
1answer
765 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> </...
1
vote
1answer
3k views

Is it safe to deactivate Workflow feature

I am unable to publish a SharePoint 2010 workflow due to the following error: “Could not publish the workflow because the workflow configuration file contains errors.” Several posts suggest ...
2
votes
2answers
607 views

Error occurred in deployment step 'Add Solution': Specified argument was out of the range of valid values

I've been working o a Timerjob project. All of a sudden, when I try to deploy the solution from VS, I got this error: Error 1 Error occurred in deployment step 'Add Solution': Specified ...
1
vote
2answers
864 views

Error while activating community site feature “Cannot add the file /sites/mysitename/SitePages/Community Home.aspx because it is a draft item”

First when I tried to activate community site feature, it gave me the below error: Site The Site scoped feature being activated has a dependency on hidden Site Collection scoped feature '...
0
votes
2answers
28 views

Folder in _Layouts/ not see

I create the project "SharePoint 2013 - empty Project", add SharePoint Layouts Mapped Folder, then add to script file, path /_Layouts/SearchWords/jquery.min.jsand publish project. I see my folder in C:...
0
votes
2answers
956 views

SharePoint Modern Hub Site - unable to Activate SharePoint Server Publishing Infrastructure

I have a SharePoint Hub site and I have created a sub-site using the Records Center template. With this being so, I have attempted to Activate "SharePoint Server Publishing Infrastructure" under Site ...
1
vote
1answer
41 views

Activate SP Server Publishing Infrastructure on Online Publishing Site -modern XP

I have a problem when trying to enable SharePoint Server Publishing Infrastructure site coll feature on one of my site... I know this has been discussed many times, but even when triying every ...
2
votes
2answers
6k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
1
vote
1answer
1k views

How do I determine a dependent hidden Site Collection feature?

When attempting to activate the Content Organizer feature for a site collection (Site Settings > Manage Site Features > Content Organizer > Activate) an error indicating that this feature is ...
1
vote
2answers
7k views

Reactivating feature with powershell - disable enable feature if it's active

$snapin = Get-PSSnapin | Where-Object { $_.Name -eq "Microsoft.SharePoint.Powershell" } #This script enables a feature on every site collection on a given web app if ($snapin -eq $null) { Add-...
3
votes
1answer
1k views

SPFx - Office UI React - How to default select user in People Picker

I want to set default selected Item on people picker? <NormalPeoplePicker defaultSelectedItems={()} inputProps={{ disabled: true }} onChange={this._onChangePeoplePicker} ...
1
vote
4answers
4k views

Error while activating custom feature

I have a wsp package installed as farm solution. package has event reciever on activating feature. When I go to Site Collection Features and activate this feature i get an error Error File ...
2
votes
2answers
108 views

Saving Site as Template Creates New Features?

New to SharePoint. Working with a on-premise 2013 SharePoint system. Im trying to save a site as a template from Production and copying the resulting template WSP file into my DEV environment. There ...
2
votes
2answers
949 views

The content type “Document Collection Folder” at “…” is sealed

It is about 2 days when myself as full control and my users try to upload a document to SharePoint 2013 assets library this error popup for them The content type “Document Collection Folder” at “…” ...
1
vote
0answers
20 views

DocID Property is not Present on Some Sites

I've been trying to activate the DocID feature on certain sites in our Site Collections. On each site collection we have the DocID feature activated following these instructions. For a long time we ...
9
votes
2answers
19k views

Getting SPWeb in feature receiver

While testing my solution I receive an error on Feature activation: Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects ...
1
vote
2answers
6k views

Feature Activation with Powershell

I am looking for a good example of powershell script for SP2010 with which I could activate my features with prior check if feature has been deployed (some are "web" and some are "site" scoped. Could ...
4
votes
3answers
6k views

The breakpoint will not currently be hit - debuging feature receiver

I need to debug my feature receiver, so I set up few breakpoints, but when I hit F5 in VS2010, they are all missed, and it says that "The breakpoint will not currently be hit. No symbols have been ...
0
votes
1answer
90 views

How to revert to default form for content type

I added a new feature and inside FeatureActived wrote following code to open my custom task form whenever user clicks on task title. SPContentType myTask = web.ContentTypes["Workflow Task"]; myTask....
0
votes
1answer
148 views

Enable-SPFeature : Field not found

I have a feature that creates a library in a site collection root, as we have 30000 site collections I cant activate it manually, I have to activate it with powershell. The problem is that when I ...
0
votes
1answer
562 views

Using feature event receiver in SharePoint Online

Is it possible to create feature event receiver in SharePoint Online? My goal is to open custom task form based on content type which I do like following in case of on-premise: Create an empty ...
0
votes
1answer
22 views

sharepoint publishing feature changed my main navigation bar

I enabled sharepoint publishing feature, because I needed anchor feature. For some reason, this changed my navigation bar. I do not know what to call it, but the first link was moved above the other ...
6
votes
3answers
22k views

Activating Site Collection Level Feature with PowerShell Script

I am trying to activate a Site scoped feature using a powershell script. I have another scrip which deploys my solution and I see my feature is installed correctly in Site Collection feature gallery. ...
1
vote
0answers
117 views

Enable Hidden Feature for Newsfeed Why?

I have seen Blogs where you can activate the "Hidden" News Feed Web Part though PowerShell and then add it to a Standard SharePoint Team Site. Enable-SPFeature -Identity "6928b0e5-5707-46a1-ae16-...
2
votes
1answer
60 views

Difference between Activating Feature in Site Features and Programmatically

I have this strange situation, i have a site definition, that has a feature that after provisioning the site has code that runs, and one of the tasks is to activate the Publishing Feature in the newly ...
0
votes
1answer
14 views

Create an owner group firstly include the site current user and assign permissions full control to it

i have used this code but when i deploy nothing changes : public override void FeatureActivated(SPFeatureReceiverProperties properties) { SPSite site = properties.Feature.Parent ...
0
votes
1answer
29 views

Error: Feature not installed and blocking for application for using this site Template

I have site template created from old site which is WSP file, both server versions are same(SP2013 on premise) What is the reason behind this three feature is not installed is there any dependencies? ...
0
votes
1answer
47 views

How can I get/identify feature titles/names in REST?

SharePoint 2013 I'm able to view all site collection active features via the following endpoint _api/site/features. I'm unable to match any of the guids to feature titles; the endpoint doesn't seem ...
2
votes
2answers
810 views

Apply Publishing Feature to all Subsites with Powershell Sharepoint 2016

I am working with a lot of site collections, which each have many subsites. I have custom branding that will only work if the publishing feature is activated on each site and subsite. I tried this: $...
0
votes
1answer
383 views

Feature activation fails “Unable to locate the xml-definition” for content types not in the feature

SharePoint 2013 on-prem. Farm solution with Web scoped feature that deploys without problems when deploying directly from VisualStudio. However, when trying to activate the feature in the normal way ...
1
vote
1answer
80 views

How do I make SharePoint 2013 menu open the content menu like in SharePoint 2010

Hi I'm basically trying to do this. Sharepoint 2013: How to customize context menu view in document library However even after I follow the instructions it doesn't work. My code is SPSecurity....
1
vote
0answers
20 views

SPLibrary: New Field added to Default View: Field still missing after update

I'm attempting to create a Site-Collection Feature in SharePoint 2013 that will create a new Site Column when activated, add this site column to every document library in the collection, and then ...
3
votes
1answer
136 views

Cannot Extract Microsoft.Sharepoint.Client.Feature.DisplayName Property

I've written a CSOM script for Powershell (code below) to enumerate the features activated on a given site. When in the foreach loop I use $f.DefinitionId, I get a list of the feature GUIDs... however ...
2
votes
2answers
119 views

Activating SharePoint Server Publishing Infrastructure

I am thinking about activating the SharePoint Server Publishing Infrastructure for our site collection, but worry what it could possibly cause. What, if any issues could this cause to content already ...
0
votes
1answer
20 views

How to deploy different files in single feature for mulitple subsites?

I need to deploy different images into picture library for different sub sites in a single feature, I mean I have five images, I need to deploy the first two image in the site collection, third image ...
3
votes
2answers
2k views

Any downsides to feature property “Always Force Install”?

Occasionally on our deployments, we would get this error Error occurred in deployment step 'Add Solution': A feature with ID {Guid} has already been installed in this farm. Use the force attribute ...
1
vote
0answers
330 views

Powershell Error on activation feature Enable-SPFeature : Object reference not set to an instance of an object

I an trying to activate a feature on site collection. I can activate/deactivate it manually and deactivate via PowerShell but when I try to activate it via PowerShell I get error of object reference. ...
2
votes
4answers
5k views

Set the JSLink property for all list forms in FeatureActivated

Is it possible to update the SPForm.JSLink property for the forms (Display, New, Edit) of an existing list in the when a feature is activated? I have tried the code below, but it seems that the ...
6
votes
1answer
293 views

SharePoint 2013 - Custom EventReceiver Feature not appearing in manage feature list

I deployed an EventReceiver Solution file on the server. The solution shows globally deployed in Central Administration. When I go to activate the feature in Manage Site Features in one of the web ...
1
vote
1answer
39 views

How to prevent multiple webpart instances after feature re-activation?

Every time I'm activating the feature that contains my webpart, a new webpart instance is added to the page layout. Do I want to this web part being replaced by its new version? What is the parameter ...
3
votes
3answers
7k views

How do I Activate the Signatures Workflow?

After fixing the intranet site that was deleted, I am re-establishing some pages that were lost. I have a site template that I created and when I try to use it on the top level site, I receive the ...
3
votes
1answer
945 views

Error when activating Project Web App Settings

I am attempting to activate the Project Web App Settings. I navigate to the Settings Wheel > Site Settings > Site Collection Features. I then click the "Activate" button to the right of the Project ...
0
votes
1answer
89 views

Error when Deactivating Farm Feature - Failed to load receiver assembly

I have a farm feature that was updated by PowerShell with the following: Update-SPSolution -Identity FILE.wsp -LiteralPath "PATH\TO\FILE.wsp" –GACDeployment I'm trying to deactivate and then ...
1
vote
0answers
1k views

SharePoint Online error - One or more field types are not installed properly. Go to the list settings page to delete these fields

Today i ran in to an error "One or more field types are not installed properly. Go to the list settings page to delete these fields". I activated the SharePoint Sever Publishing Infrastructure ...
2
votes
3answers
316 views

SharePoint TimerJob not executing

I have a TimerJob in my feature that is not executing. I've tried restarting the timer service (below), deactivating and activating the feature, and manually executing the job using the "run now" ...