Questions tagged [debugging]

Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

Filter by
Sorted by
Tagged with
20 votes
2 answers
3k views

Can't start debugging after install VS11

After I installed VS11 Dev Preview, VS2010 cannot start debugging the Sharepoint 2010 server (developer install on Windows 7). I get a nice error dialog stating: Unable to start debugging on the ...
user avatar
  • 331
18 votes
5 answers
3k views

Are there any tweaks, tips to make debugging SharePoint 2010 faster?

I am using Visual Studio 2010 Ultimate and SharePoint 2010. The debugging process itself is okay but the startup takes really long. Are there any options or hidden-hints to make this faster? Edit: I'...
user avatar
  • 890
9 votes
0 answers
543 views

Disable telemetry spam on Modern UI pages

If you open a modern page, then press F12 and open the network tab you can observe a lot of telemetry-related activities every several seconds. It makes it harder to debug SPFx customizations. Is ...
user avatar
8 votes
2 answers
2k views

Debugging remote event receiver - no context token

I am trying to use the MS supplied BasicDataOperations provider hosted app to play around with and learn about remote event receivers. I was following the instructions from this blog post by Chris O'...
user avatar
  • 12.3k
5 votes
3 answers
8k views

How to get a web.config file in a sharepoint 2010 publishing site?

I am working on a sharepoint 2010 project and I noticed in the soultion their is no web.config. I asked one of my fellow co-workers and he mentioned something about we don't have access to to it as ...
user avatar
  • 227
4 votes
4 answers
2k views

What techniques do you use to debug/test your SharePoint Timer Jobs?

I have developed a number of SharePoint Timer Jobs and they are always a bit more painful to debug and test than other areas of SharePoint. I was wondering what tools/techniques other people use to ...
user avatar
4 votes
1 answer
4k views

How to load a sharePoint page in "safe mode"?

I seem to remember that there was a way to add something to the query string for a SharePoint page that would basically load the page in a "safe mode". In this mode you could delete or edit webparts. ...
user avatar
  • 6,725
4 votes
2 answers
193 views

Debug SharePoint Solution

I'm confused which w3wp service should i choose to debug SP solution, what's the purpose of other services
user avatar
  • 187
4 votes
2 answers
6k views

Debugging SPFeatureReceiver

I have built an SPFeatureReceiver and am trying to debug it by attaching to the w3wp.exe process. No matter what I do no breakpoints are ever hit. Here are my steps Build and Package the solution ...
user avatar
  • 2,166
4 votes
3 answers
7k views

The breakpoint will not currently be hit - debuging feature receiver

I need to debug my feature receiver, so I set up few breakpoints, but when I hit F5 in VS2010, they are all missed, and it says that "The breakpoint will not currently be hit. No symbols have been ...
user avatar
  • 1,527
4 votes
3 answers
734 views

SharePoint 2013 not displaying Correlation ID when there is some error. Always displays a Runtime error page

One of my client's SharePoint 2013 site always displays the Runtime Error screen if there is some error instead of the "Sorry Something went wrong." page with the correlation ID. This makes it ...
user avatar
4 votes
1 answer
1k views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
user avatar
  • 141
3 votes
2 answers
13k views

Failed on Start (Workflow was canceled by System Account.)

When I add an "if condition" to my working workflow, It doesn't work anymore and gives error: "Failed to Start". (Workflow was canceled by System Account.) My "if condition" is in below image framed ...
user avatar
  • 133
3 votes
2 answers
463 views

Is it possible to debug the DLL of a built in _layouts application page?

I'm getting a vague error (as below) on the built-in _layouts/ChangeFieldOrder.aspx page which uses the DLL "Microsoft.SharePoint.ApplicationPages". "Object reference not set to an instance of an ...
user avatar
3 votes
1 answer
4k views

Is it possible to get detailed error messages in SharePoint Online?

When doing any sort of development/testing work against SharePoint Online, there are bound to be some errors. Some errors manifest in the form of exceptions, which can be logged to a special-purpose ...
user avatar
  • 1,680
3 votes
2 answers
4k views

How to determine if SharePoint is in Debug mode?

My SharePoint was choking on bad code in a feature. The VS12 debugger popped up and asked me if I wanted to enable debugging, and that it would update the web.config. Well, I would like to turn off ...
user avatar
  • 231
2 votes
1 answer
44 views

SharePoint 2010 - WebParts only working when debugging

So basically here's my question, I got a SharePoint 2010 website working with some web parts but the web parts only work when I'm debugging the project, when I'm not it just says that the web part ...
user avatar
  • 23
2 votes
2 answers
584 views

Debug SharePoint powershell

I create a new file in powershell ISE, it's run perfectly but I face  a bit issue I can't add break point Am I doing things wrongly !?
user avatar
  • 151
2 votes
3 answers
347 views

View callstack of unknown error

I've set <system.web> <customErrors mode="Off" /> </system.web> in my web.config file, but i'm still getting 'unknown error' instead of the stacktrace on my pages. How can I view ...
user avatar
  • 1,027
2 votes
4 answers
2k views

Debugging Feature Activation Trouble Attaching to W3WP.exe

I am using vs.net 2010 and having trouble debugging a feature activation. I have tried rebooting, reattaching etc. I have attached to w3wp processes (and vshost if it is available) and yet the debug ...
user avatar
  • 447
2 votes
1 answer
484 views

How to debug a class library on a SharePoint 2013 Server?

I am learning to create a forms-based authentication for claims-based web application using custom membership and role provider based on the [msdn][1] link I will be building a class library to ...
user avatar
2 votes
1 answer
898 views

Debug FeatureUpgrading

Trying to debug FeatureUpgrading event receiver on Sharepoint 2013. Attached localy to all w3wp.exe processes. After run $MyFeature.Upgrade($true) feature get upgraded, but breakpoint inside ...
user avatar
2 votes
3 answers
1k views

Provider Hosted application often stops debugging

I have a very weird problem. I am trying to run a very basic provider hosted application on VS2013 (Update 3). The application stops debugging every now and then. The only thing I get in Output ...
user avatar
2 votes
1 answer
2k views

Visual Studio 2013 - Workflow debugging prerequisites failed to complete

I am experiencing an issue with debugging SharePoint 2013 Workflows in a SharePoint App solution: Has anyone encountered this error?
user avatar
2 votes
1 answer
3k views

Remotely debug Provider Hosted App from Visual Studio 2015

I have created a SharePoint Provider hosted App on Azure. I need to debug it now. I have enabled remote debugging from the Azure Portal. But when I try to debug it from Visual Studio, I get the ...
user avatar
  • 1,807
2 votes
2 answers
2k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
user avatar
  • 1,527
2 votes
1 answer
1k views

Feature activation suceeds in sandboxed server environment, but fails in SharePoint Online. How do I find what's wrong?

I am currently developing a solution in C# with a feature that uses the SharePoint API to create a number of sites, lists, list views etc. The final result is going to be used on SharePoint Online. ...
user avatar
  • 1,680
2 votes
2 answers
1k views

Does anyone have ELMAH working with SharePoint?

Does anyone have ELMAH working with SharePoint 2010? I have the assembly in the bin folder and have what I believe to be the correct entries in the web.config file. I can run the test at http://...
user avatar
  • 135
2 votes
2 answers
10k views

FileNotFoundException :<nativehr>0x80070002</nativehr><nativestack></nativestack>

Error related to System.IO.FileNotFoundException. Trying to get Survey 1, Survey 2 from Custom list Survey with 2 Columns: Title Url - Contains URL of Survey 1 or Survey 2 Custom Survey list ...
user avatar
2 votes
2 answers
1k views

Workflow debugging prerequisites failed to complete - VS2013 Autohosted App

I am creating an auto-hosted app on VS2013. I am working with SharePoint Online and not locally. The problem is that when I try to enable the workflow debugging on my project I receive the error: ...
user avatar
  • 147
2 votes
3 answers
6k views

Debuging Event Receiver- Sharepoint 2013

I am trying to create ER for a document library, eg http://server.com/sites/dev I wanted to monitor document library for add and remove item. I created Empty SharePoint 2013 project ( Not sandboxed) ...
user avatar
2 votes
2 answers
1k views

How to debug sharepoint webservice?

I've followed Walkthrough: Creating a Custom ASP.NET Web Service and everything works fine. I just want to know how to enable debugging for this web service over network. Could you help me?
user avatar
  • 131
2 votes
1 answer
117 views

File transformations before packaging WSP

I need to modify the content of some files in my SP 2010 project before packaging, something like Web.Config transformations. I need a file to have different content based on the environment: Debug, ...
user avatar
  • 1,169
2 votes
2 answers
1k views

How do I debug a code-behind page in the Central Administration site

I built a custom timer job and created a configuration page (.aspx) for it. Going through the Central Administration site, I can get the to configuration page. When I enter values and click "OK" to ...
user avatar
2 votes
0 answers
272 views

Better Debugging for Sharepoint 2013 and Visual Studio 2015 [closed]

I am new to Sharepoint. I have used asp.net mvc the last 5 years and Web Forms the 7 years prior. ANY HELP is greatly appreciated in helping me get up to speed with Sharepoint development. I just ...
user avatar
2 votes
1 answer
281 views

Visual Studio debugger for SharePoint AutoHosted App

I'm using VS2013 for developing SharePoint Hosted App against a 365 development site. The VS debugger tool doesn't hit anymore my breakpoints. It used to the day before. I have made many tests, On ...
user avatar
2 votes
1 answer
987 views

Debugging custom membership provider - An unexpected error has occurred.

I used this video tutorial to get started and created a custom membership provider: http://channel9.msdn.com/Blogs/BomBom/Building-your-own-MemberShipProvider-in-ASPNET-20-and-use-it-in-SharePoint I'...
user avatar
2 votes
2 answers
9k views

Event Receiver Not Firing

I have an event receiver using the VS2010 template for SharePoint 2010 and I have coded it the same way I have done many times. This time, though, it is not firing at all. It is attached to the list ...
user avatar
2 votes
0 answers
2k views

Debugging XSLT in Visual Studio 2010 [closed]

I'm trying to debug XSLT for CQWP. I followed this guide. So I'm able to retrieve the XML, and link the files temporarily together using xsl:import. But then Visual Studio can't find the schema for ...
user avatar
  • 7,395
1 vote
3 answers
616 views

Unable to debug TimerJob in Visual Studio 2012

I have create a timer job and deployed in SharePoint 2013. Debugging worked fine couple of times. After retract and redeploy couple of times. Now while attaching to OWSTIMER getting below error. ...
user avatar
  • 466
1 vote
4 answers
3k views

Debugging sandboxed ItemUpdated event receiver - breakpoints not hit

I'm trying to debug an ItemUpdated event receiver in SharePoint 2010. I add breakpoints to the code, and hit F5 in Visual Studio 2010. I click Attach when I'm prompted to attach to the process. Then, ...
user avatar
  • 682
1 vote
2 answers
363 views

How can I stop a broken webpart from killing the whole page?

The title says it all, when there's a error in my webpart I can't load the whole page. I'd like just to don't display the webpart and still see the rest of the page and not just get the error page. ...
user avatar
1 vote
2 answers
836 views

Debugging Problem with Sharepoint Foundation 2010

I've installed Sharepoint 2010 Foundation on my WS2008R2 copy... Whenever i lanch from Visual Studio some debug, the process couldn't attach to IIS and so every break point is skipped.. To male ...
user avatar
  • 1,977
1 vote
3 answers
282 views

Debug Web Parts

I am studing this topic and I would like somebody to point me in the right direction for studying this. Debug Web Parts This objective may include but is not limited to: ULS log, and event log, debug....
user avatar
1 vote
1 answer
1k views

How to debug SPFX Web part in visual studio code ?

I am trying to find a way to debug my local SPFx workbench from Visual Studio Code, For this have installed the "skritt-debugger" and the launch.json Look Like this "configurations": [{ "...
user avatar
  • 175
1 vote
1 answer
37 views

Can't find Sharepoint timerjob service among process to attach

I would like to attach Visual Studio to OWSTIMER service to debug the execution of a sharepoint timer job, but the service stopped to appear among services to attach in Visual Studio. Any idea why ? ...
user avatar
1 vote
1 answer
234 views

Any recommendations for SharePoint Online PowerShell Debugging Tools

I just discovered code.visualstudio.com, which even has intellisense for PowerShell scripts. Debugging those scripts, especially when the target is SharePoint Online, is a different matter. Does ...
user avatar
  • 547
1 vote
1 answer
387 views

Default SPEmailEventReceiver: Object reference not set to an instance of an object

I'm trying to write a new Email Event Receiver for an email-enabled document library. When my feature is disabled, email is delivered successfully to the library. When my feature is enabled, this ...
user avatar
  • 101
1 vote
2 answers
946 views

Debugging sandboxed solution?

I know this is a novice question, but my sandboxed solution works on one site and not the other. How/where can I actually see the errors generated by some sort of report? Debugging simply takes me to ...
user avatar
  • 739
1 vote
2 answers
2k views

Possible to debug old solutions running in 2010 mode in a 2013 environment?

I've got a SharePoint 2013 VM for development using Visual Studio 2013. I've deployed an "old" 2010 wsp containing a visual webpart for using it within site collections running in 2010 mode in my 2013 ...
user avatar
  • 1,472