Questions tagged [debugging]

Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thus making it behave as expected.

30 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
9 votes
0 answers
543 views

Disable telemetry spam on Modern UI pages

If you open a modern page, then press F12 and open the network tab you can observe a lot of telemetry-related activities every several seconds. It makes it harder to debug SPFx customizations. Is ...
user avatar
4 votes
1 answer
1k views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
user avatar
  • 141
2 votes
1 answer
987 views

Debugging custom membership provider - An unexpected error has occurred.

I used this video tutorial to get started and created a custom membership provider: http://channel9.msdn.com/Blogs/BomBom/Building-your-own-MemberShipProvider-in-ASPNET-20-and-use-it-in-SharePoint I'...
user avatar
1 vote
1 answer
428 views

SPFX: How to debug an application customizer extension

I am new to spfx and have to write an application customizer that changes the key of a query in the url. I have already implemtend this functionality and now want to test/debug. When I run gulp serve, ...
user avatar
  • 121
1 vote
0 answers
1k views

New spfx web part (1.4.1) requests WsaUpload.ashx, gets 403

I just generated a new web part using the Yeoman generator for SPFx 1.4.1, and am debugging it in the hosted workbench. We are using SP2016, On Prem. I am seeing console logging that looks like this: ...
user avatar
  • 675
1 vote
0 answers
236 views

Error Thrown When Toggling 'Quick Edit' on a List or Library

For some reason users are getting the following popup/error when toggling 'Quick Edit' on a list or library. This site says... Assertion Failed: Edit manager is still in Editing state, but ...
user avatar
1 vote
0 answers
103 views

Cannot debug Provider-Hosted Add-In: VS2017 hangs opening Chrome (resolved)

Update: Resolved (hope so). Maybe this is a bug and upgrade VS2017 to to 15.7.6 helps. I close my Chrome every time before f5 -- Every How-to for beginners in the net say "Hit F5 and voila!" - but ...
user avatar
  • 1,591
1 vote
0 answers
83 views

SharePoint hosted app development, Less/Typescript and side-loading

I am doing some technology test for developing SharePoint hosted apps using Visual Studio 2013 in my SharePoint 2013 development environment. For that reason, I am trying to see how far I can push ...
user avatar
  • 6,854
1 vote
1 answer
234 views

How to tackle error raised in 1 WFE out of 3 WFE?

Someone had asked this question but proper answer is not known, can anyone say what will be the proper answer for this? We have a SharePoint application spread on 3 WFE server. Now one component is ...
user avatar
  • 273
1 vote
1 answer
175 views

How to debug why i cannot add a webpart to a page in SP Designer

I have several custom webparts which i am attempting to add to a custom page WebPartZone using SPD2010. I can successfully add one, however when i attempt to add the other i get an "Error Creating ...
user avatar
1 vote
1 answer
121 views

Adding new item to a list works in dev but not in prod

I have some code which simply gets a list, creates a new item with the appropriate fields, and adds the item to the list. The code worked perfect in the dev and UAT environments but since we deployed ...
user avatar
  • 107
1 vote
0 answers
1k views

Unable to debug in an event receiver sharepoint 2010

When i debug in the event reciever(item adding) as soon as it reached the if condition i get the following error unable to automatically step into the server.The remote procedure could not be ...
user avatar
  • 1,982
1 vote
1 answer
660 views

sharepoint framework extensions: sorry something went wrong

I am trying to learn SharePoint Framework Extensions and this is my first try. I created an application customer following the example in pluralsight. When I try to add the app, I get the error: Sorry,...
user avatar
  • 1,316
0 votes
0 answers
8 views

Sharepoint Online Provider Hosted Addin: local Debug with Azure Service Bus stopped working

We used to debug locally a Provider hosted Add-In using Azure Service Bus. Project working in VS 2019 From some days ago, the start of the application works as usual but Remote Event Receivers don’t ...
user avatar
  • 121
0 votes
0 answers
24 views

SharePoint remote event receiver debugging stuck at grant permissions page

I'm trying to create a remote event receiver for a SharePoint online dev site (referred guide - https://docs.microsoft.com/en-us/sharepoint/dev/sp-add-ins/handle-list-item-events-in-the-provider-...
user avatar
0 votes
1 answer
49 views

Troubleshooting SharePoint Online Workflows

I am using SharePoint in office 365. I am unsure the cause but in one of my SharePoint sites Workflows will not run. Workflows work just fine in other sites. It is a 2013 Workflow. Things that I have ...
user avatar
0 votes
1 answer
86 views

Issue relate to RER in SharePoint online

I am trying to create a Remote event receiver on SharePoint online. I followed steps given in the below url to create it : Steps to create a remote event receiver RER is getting deployed ...
user avatar
  • 156
0 votes
0 answers
149 views

Debugging React components in spfx client side webparts

How can I step through my .tsx code file line by line? Either using Google Chromes developer tools or Visual studio code the debugger steps into internal Typescript/JavaScript libraries? It becomes ...
user avatar
  • 2,376
0 votes
1 answer
203 views

debugging sharepoint webpart without visual studio debugging

SharePoint debugging with visual studio stop the site. I'm looking for a way to debugging SharePoint Webpart with out stopping the SharePoint site.
user avatar
  • 13
0 votes
1 answer
148 views

Sharepoint app, missing styles and images when debug

Trying to run a simple Sharepoint 2013 App in Visual Studio (however, the same thing happens with all Sharepoint-store installed apps). I have set a url http://sharepointsrv/sites/devtest/ as the site ...
user avatar
  • 73
0 votes
1 answer
138 views

Can't debug SharePoint 2010 on a SP 2010 farm environment

I'm told I can't debug on a farm environment - one admin server, one web server, one SQL database, all separate boxes. But it seems like something you'd need to be able to do, so I'm looking for ...
user avatar
0 votes
0 answers
150 views

Failed to attach to debugger

I am working on a project in visual studio, and unable to attach w3wp process in visual studio, it's showing me that the attach was right, so the red circle appears solid, but when I refresh the page, ...
user avatar
0 votes
2 answers
770 views

Remote receivers debugging using azure service bus does not work

After i published app (not sure if related) to app o365 catalog (not store) i cannot debug app installed (or uninstalling) receivers using azure service bus anymore. I even tried removing remote ...
user avatar
  • 115
0 votes
0 answers
522 views

SharePoint WebParts. Attaching to ProteusDebugEngine debugger failed

I'm using Visual Studio 2010 Ultimate and SharePoint Foundation 2010. When I debug my VisualWebParts I have some errors: "Attaching to ProteusDebugEngine debugger failed. Invalid pointer." "Cannot ...
user avatar
  • 275
0 votes
1 answer
73 views

Debug DLLs in bin folder (SP 2013)

I'm using Sharepoint 2013 Foundation. I have configured Form Based Authentication. I wrote my own project to do the authentication (compiled into a DLL). Placed both DLL and PDB files in "...
user avatar
  • 171
0 votes
0 answers
2k views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
user avatar
  • 472
0 votes
0 answers
1k views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - Init()...
user avatar
  • 681
0 votes
0 answers
78 views

How can Solve problems while debugging sharepoint web application?

Everytime I try to run my sharepoint application in debug mode, I get the error bellow:
user avatar
  • 681
0 votes
1 answer
43 views

Read init params of workflow after it started

There's a sharepoint 2010 site of which I'm administrator. This site has a library with many items and workflows. One of the workflows is behaving wrong. I would like to look at the initialization ...
user avatar
0 votes
0 answers
327 views

Sharepoint Solution showing old server url while debugging in visual studio 2010

I have a SharePoint solution which I developed in a server named HostA, and was deployed in the same server at the url, http://HostA:2100/ASD Later I moved the entire solution to a new server HostB, ...
user avatar
  • 1,021