0

caml query for bool does not work, i d not know how i could work with this issue, please any help: the result of this query is so weird: the result give me the false and true items in the same time:

<Query>
  <Where>
   <Eq>
     <FieldRef Name='Envoye_vers_Directeur' />
     <Value Type='Boolean'>False</Value>
   </Eq>
 </Where>
</Query>
1
  • Use 0 instead of False, 1 instead of True. May 15, 2014 at 18:45

1 Answer 1

1

Use 0 instead of False. If still not working try with Type='Integer'

4
  • yeah i tried Type='Integer' but no way
    – ezzaam
    May 15, 2014 at 18:59
  • Apart from that your query is fine. Double check the field name and post your code where you use this query. May 15, 2014 at 19:13
  • There might be something else going on. Like @Naim said post your code. You should use a 1 or 0 with Boolean fields.
    – lazoDev
    May 15, 2014 at 19:38
  • Just tried this with CAML Query Builder (U2U). <Query> <Where> <Eq> <FieldRef Name='InUse' /> <Value Type='Boolean'>1</Value> </Eq> </Where> </Query> <ViewFields /> <QueryOptions /> - Worked without issue May 16, 2014 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.