2

I have created New Web application using PowerShell with Windows Authentication mode using spadmin account. Application successfully created. but when I try to do create Site collection for the same Web application, I get error saying:

Sorry, this site hasn't been shared with you.

spadmin account is in farm administrator group, Managed account, Administrator on computer, site collection administrator.

What can be the problem here?

  • Can you open another site with same user account? May be browser is logging with some other account on your site. – Aanchal May 15 '14 at 4:31
  • I am able to open the central admin with same account – SharePointMan May 15 '14 at 4:35
  • Try changing the site collection administrator of that site to some other user using central admin. Then try with that user. May be there is some authentication issue with the site. – Aanchal May 15 '14 at 4:40
  • to change the site collection administrator, we need site collection right? site collection is not getting created only – SharePointMan May 15 '14 at 4:40
  • Sorry , may be i misunderstood your question. so you are not able to create the site collection. Have you tried creating your web application manually from central administration. – Aanchal May 15 '14 at 4:42
1

You have created a managed path, now you actually need to create a site collection under this managed path. So you should name the site collection url something like "http://sharepoint2010/teams/testsite.

Follwoing should be the PS command:

New-SPSite -URL "http://sharepoint2010/teams/testsite" -ownerAlias "sp\svc_spadmin" -Template "STS#0"

Moreover, the correct way of creating the managed path is

New-SPManagedPath –RelativeURL "Teams" -WebApplication "http://sharepoint2010/"

The above script will create wild card inclusion, If you want explicit inclusion just add -Explicit

0

Are opening your site in mozilla? If so please delete cookies and try to open in Internet Explorer. I have faced the same issue, and it is opening in Internet Explorer.

  • I am opening it in Internet Explorer only – SharePointMan May 15 '14 at 4:43
0

Which site templte are you using? :

  1. Custom Site Template : maybe this site template tries to add something to Taxonomy service or User Profile and the account you use does not have permission to this service
  2. Is it publishing ? : Publishing sites uses managed navigation, and same problem as 1, if the account does nto have proper permissions, you will get this error.
0

Maybe it's this user policy thing: see this technet blog

Solution: If you set the Super User & Reader Accounts to a domain account for the Web Application(s) using PowerShell, make sure they have been added to the Web Application(s) via Central Admin with the appropriate rights.

More Information: By default, the Portal Super User account is the site’s System Account, and the Portal Super Reader account is NT Authority\Local Service.

http://technet.microsoft.com/en-us/library/ff758656.aspx

0

Try browsing to the site's setting page (http://server/site/_layouts/settings.aspx), or the All Site Content page (http://server/site/_layouts/viewlsts.aspx).

This will tell you if the problem is with the home page, or with the site as a whole. For example if you can browse to Settings or All Site Content, then there is a problem with the home page.

You can then edit the page in Web Parts Maintenance mode (https://demantprasad.wordpress.com/category/how-to-go-to-the-sharepoint-page-webpart-maintenance-mode/ has some info on how to get to it), and remove any Web Parts that might be problematic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.