I am creating a site on SharePoint 2010. I have created a document library and want users to be prompted to enter information into required columns when they upload a file. I have:

  • Enabled "Allow management of content types?" under Advanced settings
  • Changed the settings for some columns in the "Document" content type to required

I would expect now that when a user uploads a document to the document library they would be prompted to enter the required fields.

Instead the document is uploaded and checked in without any prompts. When I select the document and click "Edit Properties" I cannot save the document until the required columns are entered. This is exactly the behavior I want to occur when the documents are first uploaded.

From doing extensive Google searches on the subject this should be working based on the settings above.

enter image description hereenter image description here

  • Add "Document" as the default content type. Are you using custom columns as required fields? – Aanchal May 15 '14 at 4:34
  • I am utilizing custom columns in other parts of the site but I have set up a test Document Library that is very simple. The "Document" content type is the default and Title, Company columns are both set to required. I am editing my original post with some screenshots. – user25855 May 15 '14 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.