0

"I have found some threads in here about this issue, but none of them was able to provide me with a solution.

I have an SP environment on a VirtualMachine, 1xSQL, 1xAPP, 1xWFE. In the CA I have two Web-apps, both are default set up, I have not changed anything in the IIS, AAM, DNS.

One of the web-apps I can access from both the VirtualMachine and from the "computer" my local client. But the other Web-app I cannot access propperly, from my local machine, outside the VM. It throws me with an "Sorry, something went wrong, file not found".

And I am not able to locate the corr.ID in the LOGS. This is only when entering from outside VM."

---- More info

I have three Web-Apps

server/ (server:80/) server:5000/ (this is the Central Administration) server:35000/ They are all with default settings, I have not changed anything in AAM or elswhere.

They are both on a virtual-machine. The Web-app on port 80 I can access from outside the virtual-machine, and the Central Administration I can access from outside the virtual-machine.

My server:35000 web-app I cannot access from outside. It says "Sorry something went wrong - file not found".

Then i just tried to add an AAM to the server:35000 web-app, (edit public urls --> added server:35000 to the intranet zone --> iis reset).

Now it seems to work, but I dont know if this is the right way, or why I did it this way.

  • Sorry if this is obvious but Does the URL of the troublesome app resolve to the correct IP address from your machine? – Jared McGrath May 13 '14 at 14:48
0

Please use the edit button and change your question if you can provide additional information.Yyou do not need to post an answer to do this.

There is per se nothing wrong on your part. What you describe is working as intended. Out of the box your IIS allows access from "outside" machines and clients on the well-known-http-port: 80. On Port 80 you have a web application running, which hosts site collections and so on and you can visit this site from the outside, because port 80 is opened to http traffic, as 443 is opened for SSL or 20/31 for ftp.

Now: 5000 and 35000 are not well known ports and there is no rule to allow access on these ports from the outside. You do not want your Central Administration publicly available. But of course you can make additional ports available by altering your AAM and firewall settings. Your clients would need to enter the port when accessing this web application.

  • Thanks for the advice, did not consider the edit button, my mistake. Thanks for the input. This is a intranet portal, so outside the virtual-machine is still in-house hosting. – emo May 19 '14 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.