I am trying to add some ajax functionality to a public facing site and have added a custom web service both into the layouts fodler and also into _vti_bin.

I can browse to the asmx file OK however am getting a 403 error when trying to call the service via Ajax.

Anonymous browsing is on for the site.

Am I missing something out to get it to work anonymously

On a side note I found when I browse to the asmx file in the layout folder the 'Invoke' button is available however when I browse to the asmx file in the _vti_bin folder it is not visible. Not sure if this is related


2 Answers 2


I found the problem

I had not configured the web.config in the _vti_bin folder correctly


  • 1
    Please avoid messing with _layouts or _vti_bin. Use the webapplication folder to deploy custom services unless its common and use at the enterprise level.
    – Vamsi
    Commented Jun 15, 2011 at 14:23

Is the ViewFormPagesLockDown feature enabled on your site? (note: It should be for any internet facing sites and it is enabled by default on publishing sites) This feature takes away the UseRemoteAPIs and ViewFormPages permissions from anonymous users. I ran into issues with this that are documented here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.