3

After completing the installation and configuration of Workflow manager I try the register-spworkflowservice cmdlet:

Register-SPWorkflowService -SPSite "http://env-utv-sp/sites/selvbetjening" -WorkflowHostUri "http://env-utv-sp:12291/"

(Ive verified that all the urls are ok. )

However it returns:

Register-SPWorkflowService returns : The remote server returned an error: (404) Not Found.

The uls logs adds the following:

Attempting to download security token service json metadata from 'http://env-utv-sp:12291/$System/$Metadata/json/1'  
An error occurred while downloading and parsing the json metadata document.

I found this blog entry

  • http://samirvaidya.blogspot.no/2014/02/installing-sharepoint-2013-on-windows.html
  • , and it says that Sharepoint 2013 workflows will not work on windows server 2012 r2. Has any one here had any similar problems or been able to install workflows on a windows server 2012 r2 environment?

    • 1
      what is your sharepoint installation....is it installing the RTM version and then SP1...or SharePoint SP1 ISO? are you installing WF Manager on ShrePoint servers or independent farm? – Waqas Sarwar MVP May 7 '14 at 15:15
    • Sharepoint 2013 Server 15.0.4569.1506 64-bit. independent farm and iso i guess (I did not do the sharepoint installation and the guy who did is on vacation) – Pantani May 7 '14 at 17:54
    • 1
      i am thinking two things...Windows Server 2012 R2...make sure SharePoint installed with latest ISO (SharePoint 2013 SP1) and try to register it...try to unistall the WF manager then reinstall see if that fix it. social.technet.microsoft.com/Forums/sharepoint/en-US/… – Waqas Sarwar MVP May 7 '14 at 18:38
    • Ive installed the latest cumulativ update for Sharepoint and uninstalled and reinstalled wf manager, but i still get the same error – Pantani May 9 '14 at 7:21
    7

    The solution is to launch the Web Platform Installer (WebPI) and search for "Workflow Manager". Make sure you add and install the Workflow Manager CU2 update that supports Server 2012 R2. You may also need to install the CU2 prerequisite: Cumulative Update for Service Bus 1.0 (KB2799752).

    3

    The solution is to launch the Web Platform Installer 5 and search for "Workflow Manager 1.0 refresh". Make sure you add and install the Workflow Manager CU2 Get refresh update that supports Server 2012 R2.

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.