1

We have a large SharePoint 2010 installation. On many sites, I use Export to Excel or a datasheet view to view lists larger than 5,000 items with no issue. If the list has more than 50,100 items, we only get back the first 50,100 items. (The view must be non-filtered, or filtered on an indexed column in that case)

On a single site, we are now receiving the List View Threshold error and our datasheet view fails, when we only have 17,000 items on the list.

IT doesn't get the LVT - they keep telling us this is expected behavior. However, MS documentation says Datasheet view and Export to Excel should give me 50,000 items, and all my other sites give me 50,000 items.

Has anyone else encountered this? If so, did you find a fix? My wild guess is that a server admin who doesn't understand the LVT changed a setting on a single content database, so our site now behaves differently than the sites on other content databases on the farm.

Any other ideas?

  • Did you ever find out what the issue was? – Dinerdo Apr 26 '15 at 0:20
  • I did encounter this earlier, and we created a custom solution for it. One point you keep in mind is 50000 items which is mentioned is not a fix standard, when it comes to huge number of columns. For Instance, If you have 50 or more columns and 17000 items, in this case also it is going to give LVT error. To be more precise you can consider it as a grid having x no of cells are allowed, so item count doesnt matter. – Gaurravs Dec 7 '15 at 4:57
0

List threshold defines how many number of maximum rows you can have for a single list view. We do have an option of changing default list view threshold value for entire web application through central admin, this will affect all the sites within the given web application and is not a good practice.

Another way is to disable the list threshold setting for a specific list instance through powershell script. Please look at Disable Threshold for List

This will allow your list to create views with over 5000 records. It might be possible that you had it disabled for your previous list instance and thats how you were able to get more then 5000 records.

I hope i was able to answer your question.

0

It's a setting on the web application: General Settings --> Resource Throttling. You can then disable the daily time window. I can't say I have ever used it but I would expect your indexed views or metadata filter navs to work regardless. I'd be interested to know if turning this off has any effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.