0

I have a single farm SharePoint 2013 wfe that This Site search is no longer working. It was configured correctly in the past but within the last month has stopped working. Everything and People search work without issue. Just not This Site. Any ideas would be most helpful

It was working after the changes I described below. However when we were making some changes to our setup, the server unexpectedly shutdown. Now it is not working again.

  • Any error? Or just 0 results? You have a Search Center Setup with the OOB Search Core Results webpart correct? – Michael Colbs May 6 '14 at 17:13
  • Yes I have the OOB Search core as the default. In addition, the result is Nothing here matches your search. But if I search everything, it returns results. – spninjaba May 6 '14 at 17:16
  • In addition, I have my alternate access mapping default set to https but my search center url set to http. Would that have any bearing? – spninjaba May 6 '14 at 17:32
  • Yes it would. Can you try removing the AAM for a test – Michael Colbs May 6 '14 at 17:47
  • This is in a production environment so I can't remove AAM – spninjaba May 6 '14 at 18:14
1

Make sure you have done a full crawl since the Alternate Access mappings have been configured.

Also, try adding a Search Results Web Part to a page, and in it's properties click 'Change Query'. Add this and test.

contentclass:"STS_Site" contentclass:"STS_Web"

You can play with result sources and the query itself within the window. I'm still learning each aspect of SP 2013 Search but I hope this helps troubleshoot a little.

|improve this answer|||||
  • Exactly right. In my case, the "start addresses" domain in my Search Service Content Source didn't match my Default Alternate Access mapping. This article got me pointed in the right direction. – Chiramisu Nov 2 '17 at 4:40
1

I checked the AAM. It was configured correctly to go to https main web app and was resolving without issue. It also had mapped http as an intranet address.

I did a full crawl and still no results. I then went into the start address sources for the content source and removed http main web app and hit ok. Did a crawl, and still no joy.

So I re-added http main webapp to the start addresses source and hit ok. Did a crawl and like magic This Site search is working again.

Hopefully it will continue to work as it is supposed to.

Any insight into how this might have solved it would be awesome.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.