I've been following Spence Harbar's guide for setting up a multi-tenant install of SharePoint 2013 in a testing environment.
I am following his 2010 Guide but replaced the Search Service script with the one from his SP 2013 Article.
We are using SQL Server 2014 installed on the same machine.
All servers are Windows Server 2012R2 fully patched. SharePoint is running SharePoint 2013 SP1

I can install the UPS Service Application and Proxy just fine. My issue starts to occur when I try to start the User Profile Synchronization Service (Using the script from http://www.harbar.net/articles/sp2010mt5.aspx). The service starts then stops. I have ULS log messages below.

Now, everywhere I've read points to permissions being an issue. I've done the following and ensured the following:

  • Farm account running as local admin on SP server
  • Farm account have local logon rights (also verified by logging into the server as the farm)
  • Farm user mapped to DBO for the Sync DB (I'm creating the UPS App as the farm user so this is already done, just for the record if I click on properties for the Sync DB dbo user it shows my farm user under Logon Name)
  • Attempted to create the UPS via the CA, same issue
  • Completely uninstalled SharePoint 2013, reinstalled and manually configured from Spence's guide, issue still occured.
  • Cleared SP cache
  • Manually starting FIM Sync service (This errors, more on this below)
  • No warnings or errors logged in the event log as the service is listed as Starting..
  • The farm account has Replicating Directory Changes on the whole domain.
  • My SQL server does not have a named instance. But I tried to make an SQL alias anyway
  • I discovered the 2012 Native SQL client installed but I removed it when I reinstalled SP2013 so that it relies on the 2008R2 Native SQL client.
  • Time is in sync on all servers.
  • Completely removed the UPS Application & Proxy countless times (Probably over 10-15+ times)
  • Rebooted the server countless times
  • Added the remote execute permissions and whatnot in the COM+ DTC for MIIS

My symptoms are similar to this post in that I've tried all these things yet it's still not working: User Profile Service will not Start

Error Messages

In the ULS once the UPS is provisioning I find:

ILM Configuration: Configuring database
ILM Configuration: Error 'ERR_CONFIG_DB'.
UserProfileApplication.SynchronizeMIIS: Failed to configure MIIS post database, will attempt during next rerun. Exception: System.Configuration.ConfigurationErrorsException: ERR_CONFIG_DB    
 at Microsoft.Office.Server.UserProfiles.Synchronization.ILMPostSetupConfiguration.ValidateConfigurationResult(UInt32 result)    
 at Microsoft.Office.Server.UserProfiles.Synchronization.ILMPostSetupConfiguration.ConfigureMiisStage2()    
 at Microsoft.Office.Server.Administration.UserProfileApplication.SetupSynchronizationService(ProfileSynchronizationServiceInstance profileSyncInstance).

I saw this error on Spence's other article on the User Profile Service errors, and he alluded to the farm user not having the DBO schema. I've ensured my farm user has the schema. I've even made my farm user a sysadmin and Domain Admin for the time being to troubleshoot.

Starting up the FIM Sync Service (as the farm account of course) in the Services console yields this in Event Viewer:

"BAIL: MMS(884): sql.cpp(2325): 0x80230404 (The operation failed because the attribute cannot be found)
ERR: MMS(884): storeimp.cpp(5813): Failed to get computer id info from db.
BAIL: MMS(884): storeimp.cpp(5815): 0x80230447 (Service start up has failed.  Cannot read computer_id from the FIM Synchronization Service database.)

I started hunting for the computer_id field in the Sync Database.

I found a table called dbo.mms_server_configuration which has the field in there.
To my surprise the field is NULL in my database. There is only one row in that table for me, and some other attributes are filled out but most are NULL too.

The following fields have a value other than NULL:

  • instance_id
  • fixed_schema_version_number
  • mms_timestamp
  • password_change_history_size
  • mv_schema_xml

Everything else is NULL

Short of blowing away the whole server, reformatting, reinstalling SQL/SP2013 I am completely out of ideas. I've scoured the net and tried everything I've come across.

I'll also note that I did have SharePoint Designer 2013 and Visual Studio 2013 Pro installed on this server for some dev work. These packages are now uninstalled but I hope they haven't caused lasting damage.

5 Answers 5


I ran into the same issue, user account was a farm admin, local machine administrator, had local run as rights on the server, cleared the SP cache, pretty much everything you tried I had tried.

I found out that the April 2014 CU contained a fix (http://support.microsoft.com/kb/2760265) where the User Profile Syncrhonisation service will not run when using SQL Server 2014.

I Installed the April CU (which took an extremely long time), restarted the server and on first go the service started.


I discovered what was causing this and managed to get the User Profile Service provisioned correctly.

It actually turned out to be SQL Server 2014

I took the following further troubleshooting steps after I posted this question:

  • Reinstalled SharePoint 2013 on the same server
  • Provisioned a fresh new 2012R2 VM and installed SharePoint 2013 on that, connecting to the original server's database
  • Installed SQL 2014 on the new VM, uninstalled SharePoint and Reinstalled using the new SQL server

Finally I arrived at removing SQL 2014 and trying SQL Server 2012 which then worked as planned and my whole farm deployment script worked perfectly without any issue at all.


I can confirm that this is indeed a SQL Server 2014 issue. We tried starting the UPS with SP2010 and SQL 2014. No chance of getting this to work.

Using a different SQL Server (2008 R2 in this case) just for the UPS made the sync service work.

  • Thanks what are the step to install this April CU? Do i need to first delete/unprovision the current UPS? Will this affect my current farm of going offline Thanks in Advance
    – naijacoder
    Commented May 22, 2015 at 3:01

You just need the April CU for SQL server and you would have been fine. There are some other things that you need to install with SharePoint CU and updates.


You don't need to reinstall SQL Server. Just install the SQL and SP latest CUs and reboot both servers. That worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.