0

We have SharePoint 2013 installed at my company. I maintain it. I added documents to a library months ago and these documents have always shown up in the views I created for them. But recently, the documents are not displaying and I cannot figure out why. I have not changed any of the site settings recently. The add a new document link disappeared also. If I go to the library tab and click on "Open with Explorer" the documents show up there. So I know they exist.

I checked the SharePoint 2013 site on another computer and the documents do not show up in the SharePoint views there either. I usually use IE 10 to access SharePoint, but I checked this with Firefox, same thing there. No documents display in any of the views.

I also maintain a few SharePoint 2010 sites. All the documents display in the views on this site. I've searched this StackExchange site and the internet in general and found nothing related to this error.

UPDATE: May 6, 2014

I created a new site today under the same site collection and discovered more problems. In addition to not being able to see documents in the views, I also cannot edit links (both top link bar and quick launch), I cannot copy a permissions set to create a new one and best of all, I cannot edit any pages anywhere, new or existing.

UPDATE: May 12, 2014

I noticed around the same time the documents disappeared from my views that I also cannot add users to groups in SP 2013. What happens is that the people picker does not display in the pop up window. I can remove any user.

I created a new Site Collection using the 2010 look and feel, and I can add and remove users fine there. Any chance this is related to the problems with the library views?

Can anyone point me in the right direction? Any assistance would be greatly appreciated.

Thank you.

1

Check if everything is OK on the database side. A full or read-only content database can cause similar errors in SharePoint.

Check if you are not running out of free disk space on the SQL box and none of your content DBs have grown too large.

Also check if none of your site collection quotas have been exceeded or are your site collections locked.

  • Thanks. The server still has more than 11% disk space remaining. I'm not sure exactly how to check the other items. – hcShare May 6 '14 at 17:27
  • I checked the database. It is not read-only and is not full. I never set any quotas for the site collections when I created them. Everything look fine. Thanks for the information. – hcShare May 13 '14 at 14:16
  • This was the answer. We added more drive space to the virtual server and now the documents display in my views again. Thanks for your help with this. – hcShare Jun 5 '14 at 18:52
0

I have had a similar issue after creating a List from a Template. Try creating a new view with default fields.

  • I tried that. No documents showed up in the new view either. Thanks for the reply. – hcShare May 5 '14 at 19:46
0

Does your document library contain mandatory columns? If documents are uploaded to document library using Windows Explorer and document library contains mandatory columns the files are checked out for uploader. This happens even if the document library does not support check in/out. Moreover it's not regular checkout as these files are not visible to anybody else. This should prevent workflows and other processes and users to work with incomplete metadata.

Check "Manage files which have no checked in version" in document library settings. There are listed checked-out documents including those I write about.

I expect you checked permissions as Windows Explorer view is running under your windows account you are logged on your computer but you may be logged in with different account in browser.

  • The libraries I'm looking at do not have mandatory columns. But that's good to know. I did check permissions. Thanks. – hcShare May 5 '14 at 20:52
0

Is versioning enabled on the library? If so, you may want to try this (it may be a long shot but I've seen it happen in 2010):

Go to the Library Settings > Versioning Settings. In the section "Draft Item Security" set the value for Who should see draft items in this document libray? to a different option, i.e. if "Any user who can read items" is selected, then click "only users who can edit items". Save. Go back to the Library view, and refresh, then go back to the Versioning Settings and return the setting to what it was.

In my case, I had some document libraries that were created from a customized template (customized through the GUI only, then saved as a template), no documents would show in the views, not even for the site collection administrator. In the "Site content" view the document count was showing that the library contained documents, but the views were blank, even though the draft item security was set to "Any user who can read items". Toggling to "only users who can edit items" and then back to "any user" made the issue go away.

  • I do not have versioning set on for these libraries. As a result, the "Draft Item Security" section is disabled. That's what is so strange, I do not have special settings. Thanks for this information. – hcShare May 5 '14 at 20:58
0

I suggest you - to lose no time - to create a new library and move/copy your documents there with explorer. Then - if you have time - you can detect why the old one did not work... there may be so many reasons that you can spend quite a long time there!

0

All, thanks for the responses. I appreciate your help. I ended up creating a new site collection using the 2010 look and feel. That seems to be working for now. Probably not the correct answer, but I really just needed to get something up and running. I've always preferred the look and feel of SP 2010 anyway.

Thanks again!

0

I ran into this the other day as well, your post didn't help me much but what I found was the link to the form library was going to some strange Root Folder= redirection because I had renamed the allitems.aspx view file to myfiles.aspx. So instead of opening

http://intranet.sitename/home/forms/CompanyDocuments/Forms/myfiles.aspx

it was going to

http://intranet.sitename/home/forms/CompanyDocuments/Forms/myfiles.aspx?RootFolder=%2fhome%2fforms%2fCompanyDocuments%2fForms&FolderCTID=0x012001

and it was displaying no items in the list, they could click the Company Documents header and it would display items, but that was too much work for most of my staff. So next time it happens see if it's a URL issue like this.

0

Just fixed an issue like this at work. Had to re-create the user's Windows profile.

He was able to see the documents in Chrome, but not Internet Explorer. He could also see them through IE when logged in on another computer so we knew it wasn't a permissions issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.