0

I have an odd issue where as some Excel files once clicked give me the option to open or edit and then some others when clicked launch directly into Excel Services within my browser. There appears to be no continuity with it. When Excel loads within the browser I receive the workbook cannot be opened message? All trusts are set to the web app home and child trust are ticked. I do not actually require excel web services at the moment. Am I best deleting the service application. Will this affect anything else?

Many Thanks

1

There are library settings that can control this behavior. Under library settings to to Advanced settings and select which action you would like.

Additionally, there is a site feature "Open Documents in Client Applications by Default" that you can enable.

If you have access to PowerShell you can do this for all sites with this command

Get-SPSite -limit ALL |foreach{ Enable-SPFeature 8A4B8DE2-6FD8-41e9-923C-C7C3C00F8295 -url $_.URL }

Lastly - you could remove Excel services and you should not have any issues but you will not be able to leverage the Excel Web Parts either (although you would get same error if your workbook is not compatible).

As for your errors - ULS is always your friend in getting specific information as to why it could not be opened. I would recommend finding this and correcting or notifying your workbook users of the cause vs. disabling Excel services if there is any change it is or will be used. You can still use one of the first two options and the open in browser will become a link on the document context menu.

  • Jesus, thanks for the info. Does the PS script run 'as is' or does it require any additional PS adding. – JazzyN May 2 '14 at 8:49
  • That should work as-is. – Jesus Shelby May 2 '14 at 13:08
  • JesusWould thi also work - Enable-SPFeature OpenInClient -url $_.url – JazzyN May 15 '14 at 11:05
0

Verify what the default action is set to in order to open documents in the affected library's settings.

From the Document Library's Library Settings -> click Advanced Settings -> click Opening Documents in the Browser

By default it will be set to Use the server default (Open in the browser)

Change to: Open in the client application

This will remove the confusing error that makes you think Trusted File Location.

  • David, this fixed the issue as it now opens in the client but the excel services issue still persists if I revert it back. This will do for now until we require ECS so thanks. – JazzyN May 2 '14 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.