I activated community feature in a site, for some reasons, the forms, i.e. category, discussion,... are not correct. Some fields are missing.

I open the site in SP designer, in the content type, I can see there is a column, which is supposed to be 'Title', has the '' in Title field.

I tried to use powershell, ... $field.Title = "Title";

but it shows exception, says: object is null, ....

Is there a way to update the field Title to 'Title'?

Since Title column is a built-in column, anyone knows what could make its Title ''?



I worked on this for several days, here is what I found: 1) It turns out that the Content Type 'Item' does not 'Show' any column. If I check content type in SP designer, then I can see there is a column (Title) in there, whose display name is blank (maybe '' or NULL) and it is hidden.

2) However, I could not figure out how to change its Display Name. So: 2.a) I added a column to 'Item'; 2.b) then go to database content type table, find the related row, I see the definition is a XML (was NULL). I can see that in the XML, 2 fields are there. One of them is the 'Title' field. So, I added property: DisplayName='Title' , then update the database directly. 2.c) Now, this field shows in SP designer with the displayname as Title.

3) now I go to the site UI, under content type, it still does not show 'Title' under column. But if I click link to adjust field order, it shows the Title column.

4) since 'Item' content type is referred by other content type, so I checked the other content type. Weird thing is: in all other content types, this 'Title' field does not show up under column, but in some of them, I can see it if I click to adjust column order, and in some other content type, even under adjusting column order, I still can't see this field.

I know I should not change data in DB directly. I did this just out of curiosity.

  • 1
    Are you talking about the value of the 'title' field, or the actual field name the built-in Title field is broken? Apr 30, 2014 at 2:20
  • the actual field name of the built-in Title field. the system was created by someone else before. there are several site collections, but only this ONE site collection has this issue.
    – urlreader
    May 1, 2014 at 17:02

2 Answers 2


Finally I fixed this.

The issue is: previous developer messed up some code, and for some reasons, it removed the Title field's DisplayName of the content type Item. Do not know how he did it, probably because the custom feature was developed on SP2010, then deployed to SP2013. Anyway, this generated the issue.

The solution is to reset the content type, not update. Here is what I do:

1) google "SharePoint Manager 2013", download it. 2) run it, go to the site collection, click feature node. 3) at the bottom, it has Standard Column Definition and Standard Content Type Definition. Right click both, deactivate then activate them.

Wow, the Title field's displayname come back and all content type inherit from Item shows this Title too!

It took me lots of time to fix this, hope it helps someone in the future.


I had this rare case before. Actually the field title cannot be "". It probably has a name which is an invalid character (like NULL character).

To find that out what that is use this trick: Add the field to a list, then go to create view page in that list. In the list of fields in "Create View" page, try browser "Inspect Element" on that field. You should be able to see the field's real internal name in the page source. There is a <td class="ms-authoringcontrols"> element inside of which there is a <label for="ShouldDisplay%your field name here%"> element. You should be able to see the field internal name in there. Using field internal name you can get the field in either Power Shell or a Console application and change its title.

  • no, this does not work for me. I can find the field's Title or InternalName, but can't update it since it is reserved.
    – urlreader
    May 5, 2014 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.