1

I'm getting 404 for a specific webapplication which stopped working after removing another webapplication.

The webapplication that got deleted had it's own IIS website and it's own application pool. After i removed it, my other webapplication stopped working.

The remaining webapplication that returns 404 still got it's sitecollections, including the root. The IIS site still remains, and the bindings are correct. The application pool remains aswell. The AAM remains unchanged.

I've tried to restart the iis site, the application pool, i've also made an iisreset, tried to access the rootsite from SP Designer, rebooted the application server. The dns name are still working when pinging.

Any suggestions?

2
  • Was your 404 web app extended from the deleted web app? Are you using host headers? If so, is your DNS record pointing to the correct server? Can you access the site from the server? It would be helpful if you could post a screenshot of your web apps in Central Admin and your sites / app pools in IIS manager.
    – spex5
    Apr 29, 2014 at 13:30
  • The 404 webapp was not extended. And yes i was using hostheaders, and the dns pointed to the right server. However i tried to remove the 404 webapp from the iis site and, then extended it back again to the default values, and voila, it worked! I don't know what caused the problem, but then again, everything works now. Apr 29, 2014 at 13:54

1 Answer 1

1

For anyone who run's into the same issue:

I removed the webapplication from the IIS-site and then extended it back, using the same site and it worked. However, all the custom solutions assemblies that were deployed was removed from the GAC and needed to be redeployed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.