2

I have added a image in SiteAssets library. I have referred to that image in my aspx page. While redering page, image is not rendering.

8 Answers 8

3

Few things you can check:

  • Make sure the image is checked-in, approved, published.

  • Make sure you can access the image when you directly hit the Image Url in the browser. like http://server/SiteAssets/ImageName.ImageExtension

5
  • i tried to open the image directly through Image url but it is not showing the image.
    – Abhidec1
    Commented Apr 28, 2014 at 6:37
  • that means the URL is not correct, can you share the URL (hiding the server name, etc.) Commented Apr 28, 2014 at 6:38
  • the url is http://<server>/Energy/SiteAssets/SitePages/Home/ImpactModel.png i think it is something related to the .png extention
    – Abhidec1
    Commented Apr 28, 2014 at 6:48
  • Can you try http://<server>/Energy/SiteAssets/ImpactModel.png Commented Apr 28, 2014 at 7:15
  • i already tried it is not displaying
    – Abhidec1
    Commented Apr 28, 2014 at 8:23
1

It seems to be a permission issue: if the user who is displaying the page has not permission to the /Energy/SiteAssets/SitePages/Home/ then s/he won't see the image. Move the image in an upper folder (/SiteAssets or /Images) which you are sure can be accessed by the user. For sure no issues with .png!

3
  • just found following article johnmhester.wordpress.com/2013/05/21/…. i edited and uploaded the image in jpeg format on the same path.it is getting displayed.it there any solution to upload CMYK images without editing
    – Abhidec1
    Commented Apr 28, 2014 at 7:19
  • you can upload them for downloading purposes, but you won't display them in RGB.
    – Marpio
    Commented Apr 28, 2014 at 7:32
  • Permissions ended up being my issue as well. I had recently modified some security settings in SharePoint admin center to "allow limited web only access" for unmanaged devices. I switched this back to "allow full access" and it works. What is odd however, is that the device I was on is fully compliant with intune. So im not sure why the device was seen as "unmanaged" to begin with.
    – Rex Linder
    Commented Jan 27, 2021 at 3:55
0

I also faced the same issue in SharePoint 2013, I resolved it by opening the image in Microsoft paint then saving as PNG was fixed the issue.

0

Seems the issue isolated to images with the .PNG extension as SP13 needs 24 bit PNG. You would need an image editing software for that. Other image formats (.jpeg, bmp, etc) are being displayed.

0

For me it has been the browser caching things. If I go to the location where the image is deployed and then do a refresh, it will usually fix the problem.

0

I was interested in a solution for the same problem with SharePoint 2016. Whether I tried inserting a JPG image into a Bulletin Board with a Link, From SharePoint, from Computer and neither of these options worked. So then I did as Amal who earlier advised by changing the image from JPG to PNG - Afer loading the image again into the SharePoint Asset Library and using the From SharePoint 'insert image option' I found this now worked for me! YAY! Thankyou Amal!

0

Add the image to the Style Library. For some weird reason images from the Site Assets library do not render...

-2

My understanding is that SharePoint supports only HTTPS. Therefore the URL should also https://<server>/Energy/SiteAssets/SitePages/Home/ImpactModel.png

1
  • Where have you gotten that understanding from? SharePoint on-prem surely supports both HTTP and HTTPS Commented Jan 28, 2019 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.