When i click on Content Sources on my Central Administration in SharePoint 2013. I get the below error

Cannot open database "Search_Service_Application_1_DB_2fxxxxx" requested by the login. The login failed. Login failed for user 'xxx'.

When I went to database server and when i click on + sign of respective database it was not opening. Why is this happening ?? My Search on site works fine but not able to open most of the search administration pages on central Administration. enter image description here

1 Answer 1


It appears that the Admin Database for the SSA is damaged if SQL cannot open it. I would restore it from a backup or recreate it.

I cover these provisioning options in my Search course on Pluralsight: http://bit.ly/abSearch and provide sample scripts.

  • Can you send me the steps how to recreate it.
    – user4044
    Commented Apr 28, 2014 at 13:44
  • The answer to that depends on your farm architecture. There is no one "right" answer. You need to review the search components for your farm and decide where each component should be run based on your business requirements. If you just need to recreate the search application you can use the Configuration Wizard, though I'd never do that in production. Commented Apr 28, 2014 at 15:00
  • You meant Configuration Wizard means when you navigate to abc.org/_admin/ServiceApplications.aspx and click on new and choose search service application a new iframe window opens up. is that what u meant ??
    – user4044
    Commented Apr 28, 2014 at 15:10
  • No, though that is an option. I meant the Farm Configuration Wizard. I don't use it in production. I use PowerShell in production environments. Commented Apr 28, 2014 at 18:16
  • What is the difference between Farm Configuration Wizard and PowerShell?? I guess farm configuration wizards uses the same commands and done the work. Anyway if we have to use only powershell in prod then do u have any commandlts which i can run to recreate Admin Database for the SSA
    – user4044
    Commented Apr 28, 2014 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.