4

I'm attempting to create a SharePoint workflow that creates a new item in an external list using the "Create item in [External List Name]" action available in SharePoint Designer.

Currently, I keep getting an error that states "The workflow could not create the item in the external data source. Make sure the user has permissions to access the external data source and create items." The associated User ID is the "System Account" (SHAREPOINT\system).

From some research I did, I was led to believe that the workflow uses the SP Webapp account whenever it creates a new item in an external list. As described at How to authenticate BDC to the external system?, I granted SP Webapp object permissions and metadata store permissions in the External Content Type and in the External System. I also granted it permissions on the external list and the SQL Server of the external list. This didn't work for me, though.

At one point, I changed the default SSS from my "Partitioned Secure Store Service Application" to a custom one that I created. This worked, but it also broke a few other systems on my organization's SharePoint, so I had to revert back to the Partitioned SSS. I would like to create a new target application on the Partioned SSS, but, due to the partitioning, I cannot do this. Is there a way to have my External System use the target application on my custom SSS even though it is no longer the default SSS?

Are there any other potential solutions that I may be overlooking?

1 Answer 1

0

EDIT: I updated my solution because I found a more reliable way to fix the problem:

For anyone else that has this problem in the future, I figured out what the issues were.

With regards to the SHAREPOINT\system account, it turns out that is more or less an alias used by other accounts (usually service accounts) in SharePoint. In this case, it is the account used by my application pool. Reference: About SHAREPOINT\system - what account is it? how is it determined?.

The workflow appears to actually use whatever account the designated SSS or BDC is using. In my case, my "Partitioned Secure Store Service" that my SharePoint site was using by default was running the SP_serviceapps account. I determined this by launching my IIS Manager on my SharePoint server, and finding the appropriate SSS among the various application pools. The SP_serviceapps account was listed as the identity.

Due to running into some difficulties getting my SSS to work, I decided to instead use my BDC identity. In SharePoint Designer, I first determined the service account used by my custom Business Data Connectivity service (SP_serviceapps). Second, I gave both the Sp_serviceapps and SHAREPOINT/System accounts "Full Control", "Design", and "Contribute" permissions in my External List. This is probably overkill, but I wanted to be sure that they were allowed to access the External List. Further, they originally appeared to have "Full Control" permissions, but after clicking on "Edit User Permissions" for each, the resulting dialog box did not have any permissions checked. After this, I enabled RevertToSelf on my SharePoint server: BCS problem with AuthenticationMode and RevertToSelf. Last, I went to Central Admin -> Application Management -> Manage Service Application-> [Name of business data connectivity service] -> External Systems (from view in the ribbon) -> [External System Name] -> [External System Instance Name] -> Set Authentication Mode to "BDC Identity".

Last (and this was a dumb mistake on my part), I had an incorrectly mapped identifier in my External Content Type. I had mistakenly selected "VendorEmail" as the identifier when I meant to select "VendorName". Later, when I created my "Create Item" operation, I mapped "VendorName" to identifier without noticing that it was being mapped to the mistakenly-selected "VendorEmail" and not "VendorName". I fixed this problem by creating a new External Content Type that had the correct identifiers.

After this, my workflow successfully wrote to my External List.

1
  • You should mark this answer as "Accepted," since it fixed your problem.
    – jpaugh
    Sep 14, 2017 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.