2

Wonder if you could shed some light on a variant of this situation I'm experiencing.

Typical Error when running Sharepoint Management Shell "the local farm is not accessible. CmdLets...."

Here's the scenario:

POC situation. 2 servers

web front-end (sharepoint 2010 fully updated installed here)

db / app server (sharepoint 2010 fully updated installed here, as well as sql 2012 fully updated)

Username Joe is local admin on both boxes, sysadmin on the sql server and has shell-admin role applied. Username Joe can on web front-end, but cannot use sharepoint management shell on db / app server.

Powershell version is 2.0 on both boxes - double-checked -version 2 is added in the short-cut

Tried import system modules (get the same error)

Tried Run-as-administrator (get the same error)

double-checked local administrators membership

double-checked UAC off

ExecutionPolicy is the same on both boxes.

db server role is "sysadmin".

db-shell-admin role has been applied and removed and applied and removed ... using Add/Remove-SPShellAdmin (incidentally - regardless of this setting, the web front-end has no issues with powershell administration - pressumably since user Joe is a sysadmin).

Anything I've missed?

  • Confirm Joe is a Farm Admin in SP? – David Lozzi Apr 23 '14 at 19:57
  • confirm Joe also has rights on the Config DB? also logoff the Joe from the server having issue and login again, or may be restart the server. – Waqas Sarwar MVP Apr 23 '14 at 20:03
  • 1
    Confirmed Joe is part of Farm Administrators Group. What "rights" on the ConfigDB, specifically? Joe's a sysadmin on the db-server (I've explicitly tested db_owner as well). Both servers have been rebooted multiple times. Joe is not running through a temporary profile either. Joe has been added to ShellAdmin role and tested (yes on web no on app) and then removed from ShellAdmin role and tested (yes on web no on app) – feemurk Apr 23 '14 at 21:15
  • Joe should be do on config db. Did you try to run power shell with farm admin account, the account running timer services? Are you using sharepoint power shell or windows powershell? – Waqas Sarwar MVP Apr 23 '14 at 22:57
  • I'm using Sharepoint Powershell - Joe Can be the farm account too - doesn't seem to matter which one i use. – feemurk Apr 24 '14 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.