0

I have added a search content webpart. I have changed the search query to get only results from contenttype X. This works. I have selected the display template "List". I have changed the mapped properties to show my custom columns. But they are empty. I have looked to these custom columns and they are available in the managed properties and crawl properties. I have did a full crawl. What do I missing?

Here you see the display template list and the property mappings. I have selected 2 custom columns from the dropdown.

enter image description here

Here you see the results. The out of the box column (marked green) "Title" is working fine. The other 2 custom columns (marked red) has an empty value.

enter image description here

This is the contenttype with the Title and the 2 custom columns.

enter image description here

These are the managed properties. I didnt created them and I didnt edited them. They are created by SharePoint it self.

enter image description here

enter image description here

  • Make it queryable and perform a full crawl – Robert Lindgren Apr 22 '14 at 10:05
  • 1
    then, to be sure, do a search on your centre search site (usually mydomain.blablabla/search – Salvatore Di Fazio Apr 22 '14 at 10:06
  • I have backuped the contentdatabase and restore it in another environment/farm. Now it is working! So this problem is on a high level. Someone know where to look? Maybe the settings of the search service application? – Ola Apr 22 '14 at 12:47
  • I would check the permissions of the crawler on the Content. If it's a restored Content DB that may be the problem. – Matthew McDermott Apr 23 '14 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.