I'm having trouble setting up the Partner Portal. I got a System.NotImplementedException when I ran the setup script. Can someone shine some light on this?

I am running VSeWSS using the local machine administrator account.

call 02_CreateContosoServices.bat

call 03a_BuildSolutions.bat

call 03b_PackageSolutions.bat

2010/01/03 17:45:27    Error
Error: System.NotImplementedException
System.NotImplementedException: The method or operation is not implemented.
   at EnvDTE.Project.get_CodeModel()
   at Microsoft.SharePoint.Tools.Reflection.TypeFinder.GetTypesAsCodeElement(Project project, CodeElement parent, String targetTypeFullName)
   at Microsoft.SharePoint.Tools.Reflection.TypeFinder.Find(Project project, String targetTypeFullName)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.FindClasses(Project project)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.GetClassMap(Project project)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureElementDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureDirector.GetFeatureElement(ICollection`1 directors)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceFeatureDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceSolutionDirector.ConstractElements()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SourceSolutionDirector.Constract()
   at Microsoft.SharePoint.Tools.SharePointSolutions.SolutionCreator.CreateCore(ISPProject project, IDirectorCreator creator)
   at Microsoft.SharePoint.Tools.SharePointSolutions.SolutionCreator.Create(ISPProject project)
   at Microsoft.SharePoint.Tools.Forms.SPToolWindow.CreateSolutions()

Did you check the system requirements which are listed in the readme.txt delivered in the spg? I've got the same error. It was fixed by installing: Windows SharePoint Services 3.0: Software Development Kit (SDK) Also check the version of the Silverlight SDK. Should be 2 and not 3 !

Kind regards, Andre

| improve this answer | |

We had a similar problem. In our case it was due to a different version of VSeWSS being used to create the project than was currently installed on the machine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.