I've created an Infopath form and published it as a content type to my SharePoint site. What I am trying to do now is modify the form (and content type) to include an existing site column that was previously unrelated to this Infopath content type.

During the initial publishing of the form, the wizard had the correct association options. Is there any way to get back to that configuration and add/modify?

SharePoint/Infopath 2010

1 Answer 1


You will want to create the column in the content type first. I've had mixed results with letting InfoPath create and manage the columns on promotion, in particular with updating after the fact and getting duplicate columns.

Once you have it in your content type it should become available to your InfoPath form and when you publish it you will be able to select it as a promoted column.

You can set up property promotion without going thru the wizard by going to File --> Advanced Form Options --> Property Promotion.

  • I've added the site column to the content type (the column was a pre-existing choice column). But I don't see where it is supposed to become available within property promotion.
    – Christian
    Apr 16, 2014 at 19:41
  • I don't have InfoPath available at the moment but when you are marking a property for promotion there should be site column or group box where you can choose the library name. I don't recall if that gives you access to columns or if you still have to type in the name. If the latter - make sure it matches the existing column name. Apr 16, 2014 at 20:05
  • Thanks for bearing with me. I typed in the exact name of the site column, but when I published, it simply created a duplicate. Not sure what additional complication this adds, but the site column that I am trying to associate is a choice type - so ideally I want the choices stored in the site column to show up in the form. Unsure if this requires some sort of additional data connection.
    – Christian
    Apr 16, 2014 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.