1

I wouuld like to know where can i find all registered web parts, and i'm not talking about assembley but really the web parts, like which parts are in catalog etc, are there an xml files or something.

Because i get an error in pre upgrade tool which finds some webpart type X and says that the webpart is not isntalled but it is installed. My questions is how can i check it myself, or should i register somehow.

Although in web.config the assemlbly is registered, i see webparts in catalog,i can add those webparts, but i still get this issue, very strange.

Thanks

PS: the webpart i'm talking is third party, it is a Faceted Search webpart, found on codeplex.

So i get this error message:

enter image description here

All this type of web parts are located on the => _catalogs/masterpage/FacetedSearchResults.aspx

It says they are missing, but i still can add them, the page functions well. They are located in the catalog.

  • Just as a reference - what is the actual type of the webpart? Third party, SharePoint out-of-box, internal development? – SPArchaeologist Apr 15 '14 at 11:56
  • yes, it is a third party, it is faceted search from code plex. – Shkipper Apr 15 '14 at 11:57
  • So, basically you are getting the "Missing server side dependency" style error but you can use the web part on the same site the error is raised at? Mind posting a screen of the error in the tool? – SPArchaeologist Apr 15 '14 at 12:10
  • added but strangly it isnt very good quality – Shkipper Apr 15 '14 at 12:21
0

solution 1

To resolve the web parts errors:

Take a note the ID from the Pre-upgrade report: a96a608d-61e7-186c-8fbd-1cebfac7e602

Note: The ID represents the Web part type ID which is referenced within the Content database but the supporting files are not present on the server.

In order to resolve the issue we have to logon to the SQL Server and open up SQL Management Studio

Step1 Executed:

select * from WebParts where tp_WebPartTypeId = ‘a96a608d-61e7-186c-8fbd-1cebfac7e602’

Note: Execute this query against all the content databases. If we get an output, then that’s the Content database we want to concentrate on.

From the output take the value of TP_PAGEURLID

EC9F36D8-750C-4A0D-AB4C-92947DE5372A

Step2 Executed:

select * from AllDocs where id = 'EC9F36D8-750C-4A0D-AB4C-92947DE5372A'

From output look at the

Dirname: Teams/SiteA

Leafname: Default.aspx

Browsed the above site and then click on Site Actions –> Edit page –> Add Web Part –> Advanced Web Part gallery options.

We would notice that we have closed web parts. Ideally these are the ones which are culprit and shows up as “Web Part Error” under Web Part Lists.

Solution: Add the Error Web part again to the page and then deleted it.

Note: Executed the above steps for the rest of the ID referenced under web part errors.

http://blogs.technet.com/b/sushrao/archive/2011/12/02/sharepoint-2010-missing-server-file-or-server-configuration-issues.aspx

or

Solution 2

reinstall the wsp back onto the server where the webpart is linked to (web application) - you can find this within central admin webparts page!

or

solution 3

go ahead with the upgrade .... your outcome would be missing webparts whereever they would be on the site... just install the wsp on the new server and remove!

  • That is the problem the solution 1 and 2, i tried even before but i still get errors :/ very strange if I add new web parts of the same type i just get more errors ... somehow the pre upgrade check tool doesn't see those web parts intalled on ther server. – Shkipper Apr 16 '14 at 5:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.