3

Help VERY much appreciated - on the ropes with this one. I started again with new VMs and used all the recipes and the environment is looking fairly clean. But this one is killing me.

Crawl account for both Sharepoint Foundation and Sharepoint Server Search is KETECH\sp_search Trying to crawl http://intranet.ketech.org The doc I'm searching for is in a doc list on the top page of the top level site collection at http://intranet.ketech.org

sp_search a/c is NOT a local admin on SharePoint server or in domain admins and NOT a farm admin.

sp_search a/c is the default content access account There is a crawl rule including http://intranet.ketech.org and the content source is 'Local Sharepoint Sites'.

There is only one WSS content DB showing under SQL and I've give sp_search datawriter and datareader on it.

The search just says nothing found. The crawl log under 'Local Sharepoint Sites' shows 0 successes and 2 warnings. In the windows application event log I get:

The start address http://intranet.ketech.org cannot be crawled.

Context: Application 'Search_Service_Application_-_Intranet', Catalog 'Portal_Content'

Details: Item is not crawled due to one of the following reasons: Preventive crawl rule; Specified content source hops/depth exceeded; URL has query string parameter; Required protocol handler not found; Preventive robots directive. (0x80040d07)

And then the same thing.... The start address sps3://intranet.ketech.org cannot be crawled.

I've tried ULS viewer but there doesn't seem to be anything obvious there. The only thing I wondered about was I can't remember if I created the webapp with a host header and don't know where to check.

General Environment: Demo/Dev setup, UAC and IE ESC disabled and loopback check disabled. http://intranet.ketech.org is listed in trusted sites and no proxy or 'detect automatically' setup in LAN connections in IE.

  • How is your default zone configured, it should be set up for NTLM. – Jesus Shelby Jun 13 '11 at 20:11
  • In your Content Source what URL's are you crawling? If this is 2010 then you don't need the sps3 protocol, try http. – MichaelF Aug 3 '11 at 11:39
0

check this below

1.Make sure that the default content access account has Full Read permission on the web application.

  1. Disable loopback checking.(please refer the link http://www.c-sharpcorner.com/Blogs/4996/how-to-disable-the-authentication-loopback-check.aspx)

Does your intranet site use integrated authentication? If so, make sure the defautl content access account has permissions. If not, you will need to configure custom credentials for the site access.

Crawling works just like web page browsing, so it would be very strange for a web site to allow severa pages of unathorized access before it denies access.

If ths site is on the same server, make sure you disable the loopback check. This prevents malware on the local server from bypassing web security by coming back to the same machine using an alias. There are several ways to do this, as detailed in this KB article. http://support.microsoft.com/kb/896861/en-us

The basic way to shutoff loopback checking (not ideal security, by the way).

  • Click Start, click Run, type regedit, and then click OK.
  • In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  • Right-click Lsa, point to New, and then click DWORD Value.
  • Type DisableLoopbackCheck, and then press ENTER.
  • Right-click DisableLoopbackCheck, and then click Modify.
  • In the Value data box, type 1, and then click OK.
  • Quit Registry Editor, and then restart your computer.

Also, if you have a proxy server on your network you may want to bypass it for these sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy