1

I want to see the usage reports but the excel reports shows all zeros (In site settings > Popularity Trends )

Debuuging I checked and both the timer jobs "Microsoft SharePoint Foundation Usage Data Import Minutes, "Microsoft SharePoint Foundation Usage Data Processing" are running In search crawling I used to have Scheduled Crawling but i changed it to continuously ,then also i am not seeing any results

Also in search i am load balancing which is i have 2 Query Servers and 1 Index Server . Is there a way i can check the logging DB ?Can you please suggest me how can I make it work or whats the best debugging process

  • In the usage and health settings in Central a Admin, make sure you have activated logging for this information – Robert Lindgren Apr 12 '14 at 6:13
  • Yes its already there .. – Anil Apr 14 '14 at 15:23
  • I am also facing the same issue. Dd you get any solution for this. – Sas Dec 16 '14 at 6:01
  • Thanks a lot i was able to fix it .I posted my answer below – Anil Jun 24 '15 at 16:44
2

I ran into similar situation before. It was working for awhile and all of the sudden it stopped. I noticed there wasn't anything logged to the Usage database and the log folder in the 15 Hive (default location) has a very old modified date. The timer jobs and event handlers were all in place.

What ended up fixing my problem is to change to file log location from 15 Hive to somewhere else, say /_log folder. After that I can see logs starts populating in the file system and also in the database.

  • Do you have to change the logs any where in sharepoint? And how long does it take to populate once after the logs folder is changed? Thanks – dkorra Mar 20 '17 at 18:40
1

First i ran the below command and it didn't gave any output

Get-SPTimerJob -Type Microsoft.Office.Server.Search.Analytics.UsageAnalyticsJobDefinition | Select * 

Which is when i found the issue and after going through a bunch of Blogs .This below Powershell Script did the trick for me

$ssa = get-spenterprisesearchserviceapplication "search service application"
$ssa.Status = “Disabled”
$ssa.Update()
$ssa.Provision()

Once this completes.. run the below command again

Get-SPTimerJob -Type Microsoft.Office.Server.Search.Analytics.UsageAnalyticsJobDefinition | Select * 

You will see that now it will give output and then from the next day i was able to see the analytics in the Excel Reports

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.