0

In a VS 2012 project I created "TestMasterPage.master" (a duplicate of v4.master) and added it to a module named "Module_MasterPage" below are contents of elements.xml

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <Module Name="Module_MasterPage" List="116" Url="_catalogs/masterpage">
    <File Path="Module_MasterPage\TestMasterPage.master" Url="TestMasterPage.master" Type="GhostableInLibrary" IgnoreIfAlreadyExists="FALSE" />
  </Module>
</Elements>

After deployment "TestMasterPage.master" shows up in the Master Page Gallery

enter image description here

So why not in SharePoint Designer?

enter image description here

Thank you for your help.

  • did you already published it from the browser? – Luis Valencia Apr 11 '14 at 12:57
  • Thank you @L.V.SharepointArchitect for pointing me in the right direction. See answer below – SP Combatant Apr 11 '14 at 13:27
1

I'm indebted to this exchange Publish missing in Sharepoint Designer 2010 where @webdes03 explained: "SharePoint Server Publishing Infrastructure" must be activated on the site collection and the actual subweb you're working with, it is set in both places (two separate features, one in Site Collection Features and one in Site Features).

All looks good after turning on BOTH publishing features enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.