1

I tried to retrieve results from the search api using REST call like this: http://server/Search/_api/search/query?querytext='*'&sourceid='B09A7990-05EA-4AF9-81EF-EDFAB16C4E31'

I can see the properties except one custom property I have in user profile, when I go to search results page, and edit the web part, I can see the property within the list of properties I can use to filter the results.

I have this property managed property in search configuration, mapped to user profile property, it's set as Searchable, Retrievable, Queryable, it's showing in results page to filter but I was unable to see it in REST.

0

Because it is a user profile property you also have to set security via user profile service so it is available to everyone.

EDIT:

  • From Central Administration --> Manage Service Applications Find your
  • User Profile Service Application and open it Under People --> click manage properties
  • Edit your property and make sure policy setting is set for everyone.

I have not experienced this directly with REST calls but I did come across it while building display templates, which also rely on managed properties.

  • Hi , Thanks for your reply, how do I do that? – SharePoint Freak Apr 11 '14 at 1:26
  • Edit my reply with more info – Jesus Shelby Apr 11 '14 at 1:32
  • Yes the policy already set to everyone. – SharePoint Freak Apr 11 '14 at 1:33
  • After you created the property did you also update the result types? There is sometimes a property sync message that is displayed after configuring custom managed property and you have to tell SharePoint to update it's result source (link is included in the message). – Jesus Shelby Apr 11 '14 at 1:50
  • I was not the one who created this property, the guy who configured it is not there anymore. but even when I search without defining the scope to people, it doesn't show. – SharePoint Freak Apr 11 '14 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.