2

I have a custom C# aspx page that was created to be used inside of SharePoint 2010. It uses several people-picker controls.

    <SharePoint:PeopleEditor id="peopleEditorRO" runat="server" AutoPostBack="true" IsValid="true" AllowEmpty="false" Height="35px" Width="220px" BackColor="Transparent" AllowTypeIn="True" MultiSelect="false" ShowCreateButtonInActiveDirectoryAccountCreationMode="False" ShowEntityDisplayTextInTextBox="False" CssClass="ms-usereditor" ForeColor="#2864A5"></SharePoint:PeopleEditor>

It worked great in 2010. But in SharePoint 2013 when I click on the browse icon nothing pops up. So I found this:

    <SharePoint:ScriptLink name="clienttemplates.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="clientforms.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="clientpeoplepicker.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="autofill.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="sp.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="sp.runtime.js" runat="server" LoadAfterUI="true" Localizable="false" />
<SharePoint:ScriptLink name="sp.core.js" runat="server" LoadAfterUI="true" Localizable="false" />

Now when I click on the browse icon this is what appears: A white blank pop up window. And the actual people picker popup. I can keep clicking on the browse icon and it will keep adding more popups. enter image description here

I must be missing some kind of reference. It obviously is not displaying correctly, Any ideas?

Even the ClientPeoplePicker doesn't display correctly:

    <SharePoint:ClientPeoplePicker runat="server" ID="PeoplePickerControlName" Required="true" ValidationEnabled="true"
                     InitialHelpText="text"
                     VisibleSuggestions="3"
                     Rows="1"
                     AllowMultipleEntities="false"
                     CssClass="ms-long ms-spellcheck-true" />  

I should add when I create a sharepoint page and add an iframe with the source being the aspx page. The 2010 people picker works. The ClientPeoplePicker still has display issues.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.