0

We have an SP2010 system running ordinary enterprise search.

I have an issue with contains queries using the Title managed property and another managed property called Filename.

What happens is when you do a contains query the Title query fails to recognize underscores whereas a contains query using the filename property correctly retrieves documents. I should point out we have an event handler that makes the title field the same as the document name field. So if a user saves a document name with underscores the same name is automatically replicated to the title field.

I would have thought if a system recognises underscores as a stop character then this would be consistent across the board. Anybody have ideas on what might be causing this discrepancy.

0

AFAIK Some properties use word breakers and some dont. I think Title is one of them.

If the word breaker is a problem for you, you can implement your own: http://msdn.microsoft.com/en-us/library/office/jj163981(v=office.15).aspx http://msdn.microsoft.com/en-us/library/ms693186(v=vs.85).aspx

|improve this answer|||||
  • @ArsalanAdamKhatri: my answer is an actual answer, but I added a possible solution. – Max Melcher Apr 10 '14 at 7:21
  • I guess better now, previously it looked like a comment :) – Arsalan Adam Khatri Apr 10 '14 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.