0

I found myself in a situation when workflow send http request to a service and should take response from it. But the service works for a long time. So as a result I receive "Suspended" status in the workflow due to short timeout.

How can I resolve this issue?

2

A better way to set the configuration value via powershell (s. http://msdn.microsoft.com/en-us/library/jj680843(v=azure.10).aspx).

To set the timeout to 2 min open Worflow Manager Powershell and use

Set-WFServiceConfiguration -ServiceUri *YourURI* -Name WorkflowServiceMaxHttpResponseTime -Value 00:02:00

See the Warning on MSDN Page about possible fallbacks of an increased timeout.

0

I have found timeout setting in WFResourceManagementDB database, WorkflowServiceConfig table (WorkflowServiceMaxHttpResponseTime value).

Increasing the value resolved my issue.

  • 1
    Please do not modify directly SP databases. You will save yourself a lot of trouble in the future. – luccio Apr 16 '14 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.