0

I've moved some My Sites to new content database with the powershell cmdlet Move-SPSite. However, after moving them, it appears documents were "lost" on some of them (most of sites is just fine). When I'm browsing content database itself with SQL Manager, I can see all the (missing) documents. However, they simply don't appear on the portal. In fact, the whole "Personal Document" library is not there.

Any help would be appreciated.

2
  • Which version of SharePoint? Perhaps the permissions were messed up during the move. Have you tried access the my site's personal documents library with a farm admin account?
    – Phil Greer
    Apr 8, 2014 at 15:32
  • @PhilGreer SP2010, it was done under Evelated privileges and I tried access files with admin account
    – StupidOne
    Apr 9, 2014 at 6:41

1 Answer 1

1

Check to ensure that you can access one of those inaccessible "Personal Documents" libraries and its items via powershell:

$mysitelist = (get-spweb http://mysite/personal/user_name).Lists["Personal Documents"]
$mysitelist.items

If you can access the list items, use powershell to inherit library permissions from the site with:

$mysitelist.ResetRoleInheritance()
$mysitelist.Update()

A variant of this is among some of the suggestions in this thread. If the above approach does not work, consider some of the other ideas in that thread.

Edit

If you can't access the Personal Documents libraries via powershell, then they were not copied across properly with move-spsite.

If you still have access to the original site collections, try exporting and importing the libraries with export-spweb and import-spweb.

2
  • Unfortunately, I can't see library via PowerShell.
    – StupidOne
    Apr 11, 2014 at 7:06
  • @StupidOne I updated my answer with more info. Let me know if export/import works for you.
    – Phil Greer
    Apr 11, 2014 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.