I have a problem with a provider hosted app I have developed.

In a test environment, the app ran on localhost.

Then I changed the startpage in AppManifest.xml





and deployed for production use. So there shouldn't be any references to localhost now.

If I run the app as app part in a SharePoint page the url start with localhost Are there still references to localhost yet? And where could they be?


  • how did you deploy the app? Did you change the startpage on the manifest before or after the deploy? – Salvatore Di Fazio Apr 8 '14 at 9:42
  • I deployed the with Visual Studio click the green arrow. I changed the startpage in the manifest before the deploy. I've even tried to clean the solution after the change. – Gyonder Apr 8 '14 at 9:49
  • Try with the following steps then come back and let us know: 1) change the value on the manifest; 2) create the app package; 3) deploy that manually; 4) deploy the prj to Azure; 5) install the App; 6) test it – Salvatore Di Fazio Apr 8 '14 at 9:54
  • @Salvatore Di Fazio take into account that I'm on premises.I have some problems deploying the app manually.Can you give me some steps on how to do it? thanks – Gyonder Apr 8 '14 at 10:10
  • take a look on this: msdn.microsoft.com/en-us/library/office/… – Salvatore Di Fazio Apr 8 '14 at 10:11

I've finally sorted it out. I had to publish through the site collection manually as though the catalog didn't allow me to add the app part. Then I had to change ~remoteAppUrl in elements.xml so that it pointed to my url. Hope it helps.

| improve this answer | |
  • if it solved ur problem, then plz mark it as answer. – Md. Tahmidul Abedin Feb 25 '18 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.