I have a custom sequential workflow that works fine when deployed from Visual Studio in my development environment.

To deploy to the test environment I follow the following procedure

  1. Deactivate feature
  2. retract solution
  3. remove solution
  4. add-spsolution using powershell and path to new solution file
  5. deploy solution
  6. Activate solution in the site collection

My changes however are never picked up. I've tried to recycle the SPTimer service as well as W3WP. And changed the workflow from WebApplication deployment to GAC deployment.

None seem to make a difference.

I did notice that after deployment on the test machine I dont get workflowInstanceID issues if I refresh the page on an old version of the workflow but I do on my dev environment so to me thats showing some caching. Any idea how to resolve the issue?

Update I've also tried renaming the workflows within the same package to try to force a new workflow to show up however that failed too. I've got time scheduled today to try a new GUID for the workflows but that's going to be a pain to update each deployment.

1 Answer 1


The new Workflows(2013) are hosted by the Workflow Manager Farm, you can try to recycle the Workflow Management Service.

You can try also to remove the workflows from 'wfsvc' list to have a clear situation in the deactivation of your feature implementing FeatureDeactivating in the feature reciver. For example in following way:

public override void FeatureDeactivating(SPFeatureReceiverProperties properties)
  SPWeb web = properties.Feature.Parent as SPWeb
  SPList wfList = web.Lists.TryGetList("wfsvc");
  if (wfList != null)
    SPQuery qry = new SPQuery();
    qry.ViewFields = @"<FieldRef Name='ID' /><FieldRef Name='FileLeafRef' />";
    SPListItemCollection listItems = wfList.GetItems(qry);
    for (int i = listItems.Count-1; i >= 0; i-- )
  • I've not only recycled the service, I've recycled the entire server to no avail. Something seems to be holding on to the wrong workflow DLL.
    – Mauro
    Apr 29, 2014 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.