0

I have created a reusable workflow and attached it to a Content Type that i created named "Tickets" This workflow is set to fire on a list whenever an item is changed.

The workflow works as expected when i use OOTB Edit form. Now i head over to the SPD and change my default editform.aspx for the list to a custom edit form. Set it as the default. Save and exit.

Now when i go to my list and try changing the item the workflow doesn't trigger at all.

Scenarios i tried. 1. Created a normal workflow attached it to a list. This fired when i used the custom edit form. The reusable still didn't fire. 2. Created a new reusable workflow and tried the same thing (just for the heck of it!). It didn't work.

Any help will be appreciated. Have tried googling and couldn't find any solution. Is there something that i missing !!

0

I have found the solution and it works now.

There are 2 content types on my list Item and Tickets the reusable workflow was bound to the ticket content type. When i changed the content type of the reusable workflow to the item content type, the workflow started working fine. This is quite puzzling because Tickets content type is based on the items content type.

I am still not sure why this is happening . It would be nice if someone could point me to an article which explains why this happens because is believe my limited knowledge caused this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.