1

We recently had an AD username change on our system. In SharePoint, the profile is updated except, as many people have experienced, some of the core fields like username are still stuck on the old username.

I am running the following command as the farm administrator, that I have seen suggested in multiple places:

stsadm -o migrateuser -oldlogin domain\olduser -newlogin domain\newuser -ignoresidhistory

and actually receiving an "Operation successful" message. However, nothing has changed, for domain\newuser, it still shows the old username field in some places. Has anyone experienced this issue, where the operation claims to be successful but there is no change on the server?

  • is it new ID or just display name change? did you run the full sync. this one is for all site collection where user have permission or just few site. – Waqas Sarwar MVP Apr 4 '14 at 20:53
  • Actually, the problem seemed to resolve itself over the weekend... I'm not sure if running it a few more times did anything or if really did need some sort of sync to run that only ran weekly. I'm not sure exactly what solved the problem as I tried many different things and then just let it sit over the weekend, but the above command was the only one that ever gave me an "operation successful" message, so it must have been that. – user11457 Apr 8 '14 at 18:57
  • 2
    couple of things to check, what is the Profile Sync Schedule( may be it is weekly). sometime weekly Database Maintenance job fix misc issue( i witness in my farm many time). – Waqas Sarwar MVP Apr 8 '14 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.