2


I need to edit a page in SharePoint Designer 2013.
When I open the page in edit mode, I can see the web parts but I can not edit them.
How can I do it?
(I need to add a CSS link in the Content PlaceHolderAdditionalPageHead) Thanks,Nk

12
  • What do you want to edit in the page.The page design or Webparts in it?
    – Unnie
    Apr 4, 2014 at 11:19
  • just add a link to a CSS in the web part
    – Nk SP
    Apr 4, 2014 at 11:21
  • You can not edit content of a webpart that way Apr 4, 2014 at 11:21
  • so how can I do?
    – Nk SP
    Apr 4, 2014 at 11:23
  • PlaceHolderAdditionalPageHead is no webpart though.. Open the page in Advanced Edit mode and you should be able to edit Apr 4, 2014 at 11:23

1 Answer 1

7

Edit the page in Advanced Mode (from Sharepoint Designer).
If the button "Advance Mode" is grayed, you need to enable
"Enable Detaching Pages from the Site Definition". You can find this setting on the site in the section "SharePoint Designer Settings" (http://site-name/_layouts/15/SharePointDesignerSettings.aspx)

If this option is also disabled at site settings level, go to central admin, web application->General Settings->SharePoint Designer Settings and select the checkbox to enabled detaching.

1
  • I waster an hour on other solution found untile this one.
    – RAY
    Nov 15, 2018 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.