2

I'm creating a workflow which uses fields from custom form. When I open the .xsn form in InfoPath, I'm able to see the names of all the field items on the form by clicking on the field.

However, I ran into a problem when creating a workflow in SharePoint Designer. When I use the "If current item field equals value" condition and click the "field" link, some of the item fields from the .xsn form are missing. Unfortunately, these missing fields are the ones I need.

Why do I see some fields and not others?

Thanks for any suggestions.

  • Can you figure out the Type of the missing fields, are they rich content fields ? – Arsalan Adam Khatri Apr 3 '14 at 18:50
  • Some are boolean checkboxes, the others are person/group pickers, from which I want to use the AccountID. – navig8tr Apr 3 '14 at 18:53
  • Are there any metadata values from the term store? – Kolten Apr 3 '14 at 22:26
  • No, there aren't. In fact, when I go to the term store I see this message: "The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator. " – navig8tr Apr 4 '14 at 12:16
  • stupid q, but are those fields are stored in the list? – XristosK Dec 31 '14 at 1:13
1

Just in case someone has the same question, here is how I resolved it:

I had to republish the .xsn form, promoting the appropriate fields. The fields I needed were not being promoted by default so I had selected them manually when I republished with the publish wizard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.