0

I have recently made a public sharepoint site on 365 and the search results page is only displaying blog posts & not pages. Here's an example: http://365public.arthaus-beta.com/Pages/searchresults.aspx?k=about

1
  • Did either of these answer your question? Commented Apr 18, 2014 at 14:44

3 Answers 3

1

Initially, it could be the properties of the page.

There is a setting 'Hide Physical URL's from the Search Index' which actually hides the content from the search results. This used to be cleared by default but is now selected by default so by default new pages might not be indexed (they are crawled but not indexed).

Matthew might also be right, the content type he quoted is the 'Web Page' content type. I believe the 'Welcome' page needs to be of the ContentType = Web page but other pages on the site can be other other content types as the contenttypeid posted by Matthew is part of an OR statement in the query.

0

May be you need to check your result source for the search. Currently the scope for the same might be limited to Blogs only.

0

I haven't spent much time on "Public Search" but thought I'd give it a try. I just checked my unpublished public site and it does not do this. I can search for all pages. I also checked a demo site and the behavior is correct as well. So, is it possible that you changed the Search Results.aspx page? If so can you revert it to the original and see if it is something you did?

In my case there is a Query parameter for contenttypeid:0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF390018EA875251284D5A8F0059B0597CFEC8* You can test this in your private search center and it should return pages from your public site. If it doesn't is it possible that you are using a different content type on your published pages? (I don't see how you cold, but have to ask.)

You can also try creating a new publishing page without anything but some test text and see if that is found (though you will have to wait for the crawler to index it.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.