3

I have a number of content types defined in the SharePoint Online ContentTypeHub and have recently made changes to them and republished. All existing site collections are still using the old definitions while new site collections reflect correctly the new definitions. Why are my site collections not getting the update?

Thanks

  • Go in to the advanced settings for the content type (in the hub), and selecting the option to push changes down, and click OK. Then refresh content types in all subscribing sites. I've had some trouble with getting mine to refresh as well, and found this to help-sometimes. – wjervis Apr 2 '14 at 18:36
5

In addition to republishing the content types from the hub, you will need to go into every subscriber (consuming) site collection -> content type publishing -> Refresh all content types. On this page you also have the option to view the error log - this will show you which content types could not be consumed and why. Usually it's because of a column name already existing in the site.

Also, the content type hub timer job and content type subscriber timer job(s) need to be run.... Which you don't have access to with SharePoint online (at least I don't think you do, I've only ever used on-premise). This means you may need to wait a day for your changes to take effect.

Regards

  • I forgot mention that we did refresh. – ChiliYago Apr 2 '14 at 17:41
  • We have been waiting for days and days – ChiliYago Apr 2 '14 at 17:41
  • That is unusual. The Managed Metadata Service App is what is in charge of the content type publishing, so the only other thing I can think of is if your site collections are using different MMD service applications (which isn't usually the case and if they are on the same web app then they will use the same MMD service APP). If your site collections are on difference web apps, then you can make sure they are using the same MMD service app by adding terms to the term store and making sure that they are there in all of your site collections. Does creating a new Content Type work with publishing? – TigerBear Apr 2 '14 at 18:16
  • 4
    FYI, the timer job for content type publishing in SPO is 4 hours (so days is definitely not a good thing) – Brent Ellis Apr 2 '14 at 18:37
  • Do you really need to refresh content types in each site? You don't have to do this on premises. – Gabriel Smoljár Jul 25 '15 at 7:23
0

Check your error log at site collection settings -> content type publishing -> Content Type Publishing Error Log.

Chances are you changed a column in the hub and the consuming site is giving an error that it already has a column with that name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.