1

I am using SharePoint 2013 365 and made a .css file to disable wrapping for the drop down menus and higlight with colors when I hover over them. I pointed SharePoint to my .css and when I am in "site settings" it works everywhere except the hyperlinks under "Users and Permissions".

my .css is stored under /_catalogs/masterpage/Themable/vbl/vbl.css

On the Team Site, when I go into "site settings" my navigation menus respond correctly in site settings except in one location, under "Users and Permissions". Under "Site Administration", "Look and Feel" "Site Collection" my .css code works correctly.

How do I get the no wrap and hover attributes to work on my Team Site too? I want it to be consistent through the site,e specially the Master Page!

1

If you're overriding the CSS for anchor links, use the following CSS in order (LV-HA) to override it globally. Ex.

a, a:link {text-decoration:none;}
a:visited {text-decoration:none;}
a:hover {text-decoration:underline; background: none repeat scroll 0 0 #FFF2A8; color: #4472B9}
a:active {text-decoration:none;}

a:hover, a:active {
    outline: 0 none;
}

If the above doesn't help, you could always apply specificity. Ex.

/* targets the anchor link within Site Settings Page */
.ms-linksection-listItem > a, .ms-linksection-listItem > a:link {
    color: #000000;
}
.ms-linksection-listItem > a:hover {   
    background: none repeat scroll 0 0 #D64937; 
    color: #FFFFFF;
    text-decoration:underline; 
}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.