I have a 2013 SharePoint-hosted app that is using an OData External Content Type (inside of the app itself). With smaller amounts of data it works fine, but with larger results the OData calls are giving an error message about being throttled.

<m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
<m:code>-2146232832, Microsoft.SharePoint.SPException</m:code>
<m:message xml:lang="en-US">
OData Service Connector has throttled the response. The response from OData Service contains more than '3000000' bytes. The maximum amount of data that can be read through OData Service Connector is '3000000'. The limit can be changed via the 'Set-SPBusinessDataCatalogThrottleConfig' cmdlet.

I read this article about throttling: http://blogs.msdn.com/b/bcs/archive/2010/02/16/bcs-powershell-introduction-and-throttle-management.aspx

After reading this article I've disabled the throttling for the OData Size and Timeout using this PowerShell:

$bdcProxy = Get-SPServiceApplicationProxy | where {$_.GetType().FullName -eq ('Microsoft.SharePoint.BusinessData.SharedService.' + 'BdcServiceApplicationProxy')}
$odataRule = Get-SPBusinessDataCatalogThrottleConfig -Scope OData -ThrottleType Size -ServiceApplicationProxy $bdcProxy
Set-SPBusinessDataCatalogThrottleConfig -Identity $odataRule -Enforced:$false
$odataRule = Get-SPBusinessDataCatalogThrottleConfig -Scope OData -ThrottleType Timeout -ServiceApplicationProxy $bdcProxy
Set-SPBusinessDataCatalogThrottleConfig -Identity $odataRule -Enforced:$false

I also ran it for the WCF scope as well.

But I still get the same error message. All machines in the farm have been restarted completely after running that as well. Any ideas what else would be causing this, things to check, anything?

1 Answer 1


I know this is an old question, but I recently had the same problem so I thought I'd post my solution for anyone else who finds this post.

Basically, I ran into the exact same problem, I followed the very limited information available and nothing seemed to change. So I opened a support case with Microsoft and this is a known issue. The workaround/correct procedure is to use the -FileBacked parameter on the Get-SPBusinessDataCatalogThrottleConfig command. The documentation on TechNet isn't super helpful for the parameter, stating:

Requests the throttling configuration for file backed metadata catalogs.

So in the case of this question changing the command to be:

$odataRule = Get-SPBusinessDataCatalogThrottleConfig -FileBacked -Scope OData -ThrottleType Size -ServiceApplicationProxy $bdcProxy
Set-SPBusinessDataCatalogThrottleConfig -Identity $odataRule -Enforced:$false

That worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.