0

I have figured out a way to uninstall and remove the wsp from manage farm solutions. (Solution Management) - http://centraladmin:8888/_admin/Solutions.aspx

But I donotknow how to uninstall and delete the feature. Because, when deploying some projects via VS we get error as given below, how do I remove the these features causing problem:

Error occurred in deployment step 'Add Solution': Failed to load receiver assembly "InternalMaster, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b11cf6a2b4fe2871" for feature "InternalMaster_Activate Internal Master" (ID: 28083f8d-cdac-4869-86d7-594b7890536d).: System.IO.FileNotFoundException: Could not load file or assembly 'InternalMaster, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b11cf6a2b4fe2871' or one of its dependencies. The system cannot find the file specified. File name: 'InternalMaster, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b11cf6a2b4fe2871'
at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection) at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) at System.Reflection.Assembly.Load(String assemblyString) at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject()

WRN: Assembly binding logging is turned OFF. To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1. Note: There is some performance penalty associated with assembly bind failure logging. To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Sometimes it gives error as feature is already present, set force to true.

If we set the feature property 'force' then it gives foll. error on deploying via VS:

Error occurred in deployment step 'Activate Features': Operation is not valid due to the current state of the object.

  • How did you 'figure out a way to uninstall'? Try a IISRESET or reboot, that may clear things up. – David Lozzi Mar 28 '14 at 12:35
  • Are you saying that you set AlwaysForceInstall = true and you still get error – Nadeem Yousuf Mar 28 '14 at 12:39
  • yes I get the last error. – variable Mar 28 '14 at 12:41
1

As is evident from the first error there is an issue with finding assembly information. This may mean you may have changed namespace, class name etc. Normally AlwaysForceInstall = true should take care of the feature which is not uninstalled. Value TRUE specifies that the Feature is installed by force during installation even if the Feature is already installed. Moreover, the second error reinforces that something has changed in the solution. Check the Elements.xml file where assembly information for the event receiver is available. Check that your namespace, class name are correct. See this for more info: http://suehernandez.wordpress.com/2011/03/31/error-occurred-in-deployment-step-activate-features-operation-is-not-valid-due-to-the-current-state-of-the-object/

0

Try this free tool from community!
Using this tool you can remove faulty features.
I hope that the error will disappear.
May be solve your trouble!

  • 1
    Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer – Benny Skogberg Mar 28 '14 at 14:22
  • 1
    Great! Looking forward to it! – Benny Skogberg Mar 28 '14 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.