I dowloaded SP2013 FBA pack from here, and I installed it. The installation works well, I have now the FBA features. But when I click on "FBA User Management", it returns the error :

A Membership Provider has not been configured correctly. Check the web.config setttings for this web application.

I have to precise that I'm able to log both with Forms and AD. I check the web.config files of my web app, of the Central Administration and of SecurityTokenService(STS). Everything is ok. I can't figure out why I still got this error.

Any help would be appreciated



  • I changed all string connexion method to "Integrated security". Now it works... If it can help !
    – Nico
    Commented Mar 28, 2014 at 14:08
  • This didn't work for us, could you provide that part of the connection string?
    – Aaron
    Commented Oct 12, 2015 at 20:35

1 Answer 1


If you're getting this error, but you can login with forms, then your SecurityTokenService configuration is ok, but there's an issue with your web application settings (web.config/machine.config).

One possibility is that the SecurityTokenService app pool and Web Application app pool run under different different user's, and only the SecurityTokenService app pool user has permissions to the membership database.

Double check your settings against the guide here: http://blogs.visigo.com/chriscoulson/configuring-forms-based-authentication-in-sharepoint-2013-part-1-creating-the-membership-database/

If you continue to have issues, check your SharePoint log file after you attempt to access the SharePoint User Management page and hope that there's a helpful error message.

  • Thanks for your reply. The guide you've link is the one I followed. As my comment says, change web.config/machine.config with the Integrated Security in "connectionString" fixed it (I guess!). Because I checked all the config, rights on database, and evertything was ok.
    – Nico
    Commented Apr 2, 2014 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.