1

So I have a sharepoint 2010 server farm. I have a separate custom intranet that I want to have sharepoint crawl. The custom intranet is a .net website. The default page allows anonymous authentication. However clicking any other page send does a http 302 redirect to another Login page that automatically takes your login credentials, logs you in and redirects you back to the page request. One time. SharePoint search crawls the first page then fails going anywhere after that. The crawl logs give many warnings, here is one example:

The URL was permanently moved. ( URL redirected to http://customintranet}/Login/Login.aspx?ReturnUrl=%2fpoll.aspx )

I have a hunch that the crawler just dies here and 302 is the culprit. If I use my browser as the sharepoint search account it works fine. I can browse the site. Is there any trick I can do?

On the content source box where I add the links, I entered the link above thinking I could run that first, in a sense, cook the site first by avoiding the redirect and it would work and the next line would just be the root link. However it keeps saving the root link first followed by the Login link in that order on the text box. Also just paling the Login link above only in the content source text box does not help either. It still errors out.

UPDATE: I discovered that in the crawl rules you can specify form credentials. Our custom intranet does contains a login form page. I choose the form option but when I click the Get Credentials button it just hangs at the Loading dialog. Same for cookie credentials. I notice there is an option to load a cookie but I am not sure how to go about doing that. I assume cookies also have some kind of server timestamp that needs to be swapped out regularly.

Anyone ever encounter this kind of issue before?

1

Can you set the Login Page as the Start Address then access the rest of the intranet so you don't have the URL? Alternatively, can you design the login experience so that the UserAgent of the SharePoint crawler is handled differently?

2
  • I tried pasting the link where I get automatically logged in in the content search list box first followed by the root link. But after the save it keeps rearranging putting the root link first. i'm also going on the assumption that it treats it in said order. I'll look at the UserAgent thing but I think I would have better luck just making login optional on the custom intranet. Everyone can read anyways I believe. Login is only for editing anyways. – fraygos Mar 27 '14 at 21:47
  • You can also watch the traffic through fiddler and see how the requests are being handled, or you can make login optional for the crawler. You have a lot of different choices. – Matthew McDermott Mar 28 '14 at 0:11
0

Is there a proxy server/script involved? Often the browser has the correct proxy settings but the Cookie Credential page doesn't.

2
  • In the crawl rules when I try to open the page to pass the credentials I mentioned that it hangs. I found out why. Apparently sharepoint goes to the internet to translate the page or some such. Since I am on an intranet server and restricted I get denied. It goes here [link]microsofttranslator.com/… I have no idea how to set this Forms AuthProxy page. Totally new to me. Investigating. – fraygos Mar 27 '14 at 21:49
  • You can specify a proxy in the Search Administration. But it it requires authentication you might not be able to set it. Would a HOSTS file entry for microsofttranslator.com to 127.0.0.1 work? That request would then just fail. Worth a try? – Steven Van de Craen Mar 28 '14 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.