2

I have a blog site in sharepoint 2013. I've to make the entire site anonymous. The anonymous users are able to view the posts but if I try to comment on a post as anonymous user, it shows error that Access is denied. You do not have permission to access this resource or perform this operation. What else I am required to do?Can anyone please help me?

Thanks in advance!

1

To allow users to post comments on your blog you should follow this steps:

  • 1st) allow anonymous access to the blog site.
  • 2nd) go to site contents and go to the comments list. Open the ribon and click Shared With.
  • 3rd) click advanced on the popup and select "stop inheriting permissions" button.
  • 4th) click Anonymous Access button and select "Add items" checkbox.

Now anonymous users are allow to post comments on your blog.

by the way, you should consider set up some kind of moderation/publishing approval mechanism in the comments list configuration page.

0

Once anonymous access is granted to the web appliaction and the site, the List Settings (of the Blog Comments list) should have an option in the ribbon for Anonymous Access. Use that button to allow anonymous to write to the list.

However - I would strongly caution against this. There are many areas of SharePoint that really should not be exposed to anonymous access. I would suggest using Facebook comments or Disqus for comments.

  • I've tried by allowing anonymous access on lists too. Still not working. – Priya Mar 26 '14 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.